98 sle - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-14-2009, 11:40 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
BonnevilleBran's Avatar
 
Join Date: Apr 2009
Location: Philly
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
BonnevilleBran is on a distinguished road
Question 98 sle

112k on the dash, just got the car a week ago
For some strange reason my car is blowing heat to the floor and out the back vents while im driving even when i keep hitting the off button...anybody else ever had that problem...oh and my A/C is blowing hot air 2...it just started happening out of nowhere and the day before everything was working fine.
BonnevilleBran is offline   Reply With Quote
Old 07-14-2009, 03:43 PM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Sounds goofy. Do you hear the blower motor running when you've selected it to be off?

Do you have the manual **** or automatic digital climate controls?
BillBoost37 is offline   Reply With Quote
Old 07-14-2009, 05:13 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
BonnevilleBran's Avatar
 
Join Date: Apr 2009
Location: Philly
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
BonnevilleBran is on a distinguished road
Default

No. It only starts to let the hot air in while im in motion.
and i have the automatic climate control
BonnevilleBran is offline   Reply With Quote
Old 07-14-2009, 05:23 PM   #4
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

its your air mix actuator.

Do a search here for that. Also have you disconnected the battery since you've owned the car?
Toddster is offline   Reply With Quote
Old 07-14-2009, 05:33 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
BonnevilleBran's Avatar
 
Join Date: Apr 2009
Location: Philly
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
BonnevilleBran is on a distinguished road
Default

yeah my dad disconnected it before...i forgot why tho.
BonnevilleBran is offline   Reply With Quote
Old 07-14-2009, 06:20 PM   #6
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

probably to confirm that the actuator was broke
Toddster is offline   Reply With Quote
Old 07-14-2009, 06:26 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
BonnevilleBran's Avatar
 
Join Date: Apr 2009
Location: Philly
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
BonnevilleBran is on a distinguished road
Default

no sir. i think he just did it 2 clean the terminals.
this was before the car started pouring in hot air. so I'm putting 2 and 2 together...that maybe the reason that its broken now..is it an expensive fix?
BonnevilleBran is offline   Reply With Quote
Old 07-14-2009, 06:33 PM   #8
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

the air mix actuator for your car can be bought from here at a very reasonable price,



and the write up on the install can be found here you want the second half of the article btw
Toddster is offline   Reply With Quote
Old 07-14-2009, 07:56 PM   #9
Senior Member
Posts like a Turbo
 
Geforce's Avatar
 
Join Date: Dec 2008
Location: Mississauga Ontario
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Geforce is on a distinguished road
Default

time for some duct tape
Geforce is offline   Reply With Quote
Old 07-14-2009, 08:47 PM   #10
Member
Posts like a V-Tak
Thread Starter
 
BonnevilleBran's Avatar
 
Join Date: Apr 2009
Location: Philly
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
BonnevilleBran is on a distinguished road
Default

thanks everyone for your replies.
i will update on the results
BonnevilleBran is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Will a 95 SLE exhaust manifold fit on my 99 SLE? radomirthegreat General GM Chat 6 03-28-2008 01:10 AM
2003 SLE Exhaust - On A 1999 SLE? toxictelevision Performance, Brainstorming & Tuning 3 02-23-2003 07:41 AM
Performance Shifting in 99 SLE? toxictelevision Performance, Brainstorming & Tuning 1 02-10-2003 01:37 AM
The Mysterious SLE's fuddyduddy121 General GM Chat 2 12-27-2002 09:47 PM
Pics of my 99 SLE boseman350 Your Ride: GM Pictures & Videos 2 12-31-1969 08:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:14 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.