'98 SE starts rich and stalls when it feels like it..help! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-24-2006, 03:24 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2006
Location: Pittsburgh, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
hotrod53 is on a distinguished road
Default '98 SE starts rich and stalls when it feels like it..help!

Here'* a little background....at 98K the engine blew, spun the bearings. Replaced the motor, spun the bearings in 20 miles! Replaced the engine again, spun the bearings again in 20 miles! Third engine.....found out that the oil pressure bypassed the first time that the engine went to high rpm, but pressure did not come back up when you let off the gas....replaced the oil filter mount where I'm told there is a check valve. We put probably 2000 miles on this new engine that has 54K on it. First problem.....check engine light...replaced something in the emmission system..installing mechanic did it, I don't know exactly what it was. Second problem...stalls at will, it may run for 2 weeks and then stall twice in the same day. When it stalls there is no warning, it'* just like the key was shut off. Pop it in neutral and it restarts every time. Third problem...every time you start it, it runs rich for about 10 seconds. There was a code once...knock sensor. I replaced the knock sensor and later found that there was a plug wire pinched between a plug and the manifold, it had burnt thru.

Any suggestions on why the motor stalls? Any suggestion why the engine runs rich on startup?

Give me a small block and I'm right at home. These newer engines are somewhat a mystery to me.

Thanks for you help!
hotrod53 is offline   Reply With Quote
Old 12-24-2006, 03:35 PM   #2
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

Is it stalling while driving or at idle?
How did you determine that it'* running rich at start up?
Technical Ted is offline   Reply With Quote
Old 12-24-2006, 03:45 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2006
Location: Pittsburgh, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
hotrod53 is on a distinguished road
Default

It stalls while driving, the other day I was moving slowly in a parking lot and blahhhh. My son had it stall at 40 MPH. Today I had it stall in a parking lot, I kicked it into neutral and restarted it. 50 feet later it started to stumble but never quit, it cleared itself up and I kept going...that was a first for that scenario.

When hot, sometimes it doesn't want to start . When cold, it always starts up but you can tell that it'* loaded up. It runs like its loaded up and the rich fuel fumes are noxious. It feels like it needs revved up to clear it up. Once running, it never does it again.
hotrod53 is offline   Reply With Quote
Old 12-24-2006, 03:49 PM   #4
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

Let'* check for a faulty fuel pressure regulator. See if there is fuel getting into the vacuum line going to the FPR. If so replace the FPR.
Technical Ted is offline   Reply With Quote
Old 12-24-2006, 04:04 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2006
Location: Pittsburgh, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
hotrod53 is on a distinguished road
Default

I pulled the vacuum line off of the FPR and I don't see any signs if fuel. There was no visible liquid so I smelled the line on each end, there is a hint of a fuel smell on the FPR end, but not on the end by the throttle body. I don't think that it'* leaking fuel thru the diaphram from what I can tell.
hotrod53 is offline   Reply With Quote
Old 12-24-2006, 04:08 PM   #6
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2006
Location: Pittsburgh, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
hotrod53 is on a distinguished road
Default

Here is another possability......I replaced one of the terminals connecting to the battery with a crappy looking clamp on terminal. This isn't the one that goes to the starter, but the one that probably powers everything else. I guess that it'* possible that it'* causing me problems.... I wouls assume that it I lost that connection, all accessory power would be dead.
hotrod53 is offline   Reply With Quote
Old 12-24-2006, 04:13 PM   #7
Senior Member
True Car Nut
 
Join Date: Feb 2006
Location: Somewhere different on the globe every month....
Posts: 2,896
Thanks: 0
Thanked 0 Times in 0 Posts
Cheetah is on a distinguished road
Default

You'd be suprised what a bad battery connection will do to these cars. Pull em' and clean em'

My car went dead teh other night - dead - no nothing while turning into my apartment complex. The + terminal to the battery was loose
Cheetah is offline   Reply With Quote
Old 12-24-2006, 04:40 PM   #8
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

Definitely check those cables. If you’re still having trouble check your coils, plugs & wires. Keep track of which cylinder each plug comes from & let us know what you find. Here'* an article on checking coils.
http://www.bonnevilleclub.com/forum/...e=article&k=33
Technical Ted is offline   Reply With Quote
Old 12-24-2006, 04:50 PM   #9
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

Another stupid question here... Did your mechanic ever perform a Crack Variation Learn Sequence when he changed out the engine/*?

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 12-24-2006, 08:01 PM   #10
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2006
Location: Pittsburgh, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
hotrod53 is on a distinguished road
Default

Another stupid response...A crank vari what???? My small block 350 doesn't have one of those so I'm lost.

I can call and ask the guy and he would gladly do it for me, tell me what it is and what it does so that I can sound like I know what I'm talking about when I ask.

In case I havn't said it before.....this is great! I appreciate all of you guys pitching in to make suggestions regarding this!
hotrod53 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Changed all fuel injectors and runs rich..too rich mark4317 Chevrolet 27 09-14-2014 02:12 PM
1999 Bonnevilee SLE Starts and stalls within 10-15 Seconds cashmgr 1992-1999 12 11-29-2011 11:02 AM
95 help starts/ stalls/ no restart sometimes fast86gn 1992-1999 2 07-10-2009 09:31 PM
so this is what boredom feels like. plea for help jwakamud Lounge 8 10-05-2006 09:31 PM
Car starts then stalls instantly --- Help! biedle 1987-1991 18 03-04-2006 08:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.