95 SSEi Blower not working at any speed?? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-31-2003, 12:45 AM   #1
Avi
Junior Member
Thread Starter
 
Join Date: Oct 2003
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Avi is on a distinguished road
Default 95 SSEi Blower not working at any speed??

Just bought a 95 SSEi the blower will not work at any speed. I changed the module with a new one, the fan looks new, changed the controler, and got a used HVAC programmer from a wrecker which I just put in, still nothing. Any ideas?? There is no power gettting to the blower or the module, so I'm assuming it has to be the programmer. It is a used one is there any way to test them?? Thanks Avi
Avi is offline   Reply With Quote
Old 10-31-2003, 02:38 PM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Which module did you change?
fuddyduddy121 is offline   Reply With Quote
Old 11-03-2003, 05:13 PM   #3
Avi
Junior Member
Thread Starter
 
Join Date: Oct 2003
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Avi is on a distinguished road
Default

The blower module that is locted inside just in front of the firewall
Avi is offline   Reply With Quote
Old 11-03-2003, 05:46 PM   #4
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Sounds like the blower control module. Does the climate control work otherwise... Can you change the temperatures and fan position settings?

And you've checked for voltage at the blower while changing fan speeds - should range from 0 to 12. You also should check voltage at the blower control module. You're looking for the grey/black wire (at least on the 92-93.) Don't forget to connect the other cable on the multimeter to a ground. Should range from 0-8 there.

Try this:

http://www.bonnevilleclub.com/forum/...pic.php?t=5920
fuddyduddy121 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
99 bonneville blower not working rmangman 1992-1999 5 07-11-2009 02:36 PM
Heating not working-Blower motor gone bust. (UPDATE) 94BonnieSE 1992-1999 17 11-13-2006 03:04 PM
Heater blower is not working; It's WINTER!! dsh12 2000-2005 17 12-29-2005 02:35 PM
blower fan not working 98sse fantascp 1992-1999 1 12-21-2004 06:43 PM
Twilight Sentinel working then not working on '95 SSEi mrstangblb 1992-1999 1 12-03-2004 09:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.