'94 SSE Parasitic Short - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-29-2004, 06:13 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2004
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
dougworner is on a distinguished road
Default '94 SSE Parasitic Short

Ok,
I checked current between negative battery terminal and cable. I get any where from .78 to 4.5 amp draw. I get .78 if I immediately unscrew negative terminal and check, but I get a 4.5 amp draw if I leave it disconnected for 5-10 minutes and then go back and recheck.

I check all the fuses and and I have only two that are drawing any current. One draws .15 another draws .01, all the rest draw 0. I can't see how a .15 or a .01 draw would cause a .78 to 4.5 draw on the battery. I think one fuse was for the radio and instrument cluster and I forget what the .01 fuse was. I wrote them down but it is in the car. I unpluged both fuses, and I still get a .78 to 4.5 amp draw on the battery so these can be eliminated.

Ok, let'* see how smart all you are.

What troubleshooting should I do next?
dougworner is offline   Reply With Quote
Old 12-29-2004, 07:39 PM   #2
Senior Member
True Car Nut
 
Join Date: Feb 2004
Location: Western MA
Posts: 2,708
Thanks: 0
Thanked 1 Time in 1 Post
randman1 is on a distinguished road
Default

So you checkes all the fuses? The I/P fuse box, relay center fuse box , left and right underhood fuse boxes?
randman1 is offline   Reply With Quote
Old 12-29-2004, 08:28 PM   #3
Senior Member
Posts like a Supercharger
 
Join Date: Apr 2004
Location: Wisconsin
Posts: 185
Thanks: 0
Thanked 0 Times in 0 Posts
int_53185 is on a distinguished road
Default

sounds like a sticky relay...try unplugging relays one at a time.
int_53185 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 Olds 88 parasitic drain! Finding short! (fixed) AdrenalineJunky Oldsmobile 36 06-17-2011 02:04 AM
Long start, short start, long stall, short stall :-( jessie_harbin 1992-1999 3 03-12-2006 11:40 AM
Parasitic Short dougworner Everything Electrical & Electronic 16 01-03-2006 01:10 AM
Parasitic power drain - air compressor / pump phuntism 1992-1999 6 09-15-2005 01:12 AM
'94 SSE Parasitic Short dougworner 1992-1999 2 12-29-2004 08:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:23 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.