93 Bonne SE na surges at idle - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-31-2011, 09:39 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2008
Location: Tipp City , Ohio
Posts: 246
Thanked 18 Times in 13 Posts
ssei98 will become famous soon enoughssei98 will become famous soon enough
Default 93 Bonne SE na surges at idle

The engine on my 1993 Bonneville SE surges at idle. It idles fine some times, then for no good reason revs up to 1500 tp 1800. Also having trouble getting the tranny to stay in overdrive. It wants to downshift without being prompted by the throttle then it won't go back into OD until you turn off the engine and restart it. Both problems appeared at the same time, not sure if they are related.
Checked for vacuum leaks, seems fine, steady at 20 inches vacuum. Replaced the Idle air control this week. The TPS is about 2 yrs old. I am getting codes 13 ( 02 sensor), 21 (TPS high voltage), 34 (MAF), 39 (TCC), 42 (electronic spark timing)
Looking for sugestions of what to try next. Thanks
ssei98 is offline   Reply With Quote
Old 11-01-2011, 08:10 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

did you clean the iac seat when you replaced the iac? you can spray tb cleaner around vacuum joints, tb gasket area, intake man gasket area listen for engine to change pitch.
jwfirebird is offline   Reply With Quote
Old 11-01-2011, 11:44 AM   #3
Senior Member

True Car Nut
 
sseidriver97's Avatar
 
Join Date: Mar 2010
Location: Portage mi
Posts: 7,124
Thanked 3 Times in 3 Posts
sseidriver97 is on a distinguished road
Default

unplug the maf sensor and see if it gets better as for the tcc code you may be low on trans fluid or have a bad tcc switch
sseidriver97 is offline   Reply With Quote
Old 11-07-2011, 10:20 PM   #4
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2008
Location: Tipp City , Ohio
Posts: 246
Thanked 18 Times in 13 Posts
ssei98 will become famous soon enoughssei98 will become famous soon enough
Default

Now what? I have not been able to figure out what is going on. Now I have another symptom. The trans will not engage in reverse or first for a few minutes when you first start it in the morning. It will rev to 2,000 or 3,000 rpm and just barely move the car. Once you get it warmed up it starts to act just fine upshifts and down shifts just fine, except for the issue with it coming out of overdrive and going back into drive. After the first start in the morning when ever you start it it goes right into gear just like it should. I added a bottle of Lucas oil trans fix and nothing changed. Could there be some kind of electrical problem causing 3 seeminly unrelated symptoms ?
ssei98 is offline   Reply With Quote
Old 11-16-2011, 08:47 PM   #5
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2008
Location: Tipp City , Ohio
Posts: 246
Thanked 18 Times in 13 Posts
ssei98 will become famous soon enoughssei98 will become famous soon enough
Default

Checked my maintenance records and found out that I had purchased the TPS a couple years ago from Aotozone for $19.00. So I decided that maybe a $19.00 part will only last a couple years. Went to Advanced and bought a TPS with a lifetime garantee for $50.00. Sure enough that was the problem. Idles fine and runs good. Disconnected the battery to clear the codes on the computer. All the codes went away except the TCC. The transmission still slips sometimes in the morning when you first put it in gear but, it drives fine from that point forward. It will only stay in overdrive on the highway if you use the cruise control. Once it drops back into third it will never go back into OD until you turn it off and restart it. Is there any way that the problem with slipping in the morning and the TCC being bad could be related? Would it make sense to replace the TCC or would it be time to rebuild the entire transmission? Ole' Nellie Belle has 320,000 miles on the clock. What should my next move be?
ssei98 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine Stalls, Surges and Stumbles after Engine Wash marquette97 1992-1999 5 04-10-2008 01:43 PM
97 SE surges at 2000 rpm?? Trev 1992-1999 11 01-12-2006 02:26 PM
Update - engine surges at idle when engine is warm billha 1992-1999 8 06-28-2005 12:55 PM
94 bonnie ssei surges,no power at wot. musicman6970 1992-1999 2 03-17-2005 04:02 AM
2000 SSEi idle surges Custom88 2000-2005 3 06-23-2003 03:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.