2 o2 sensors? - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-26-2010, 06:33 PM   #21
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2008
Posts: 90
Thanks: 0
Thanked 2 Times in 1 Post
Richardyuyu1 is on a distinguished road
Default

Ok I'll test everything tomorrow and let you know what I find. thanks Dan
Richardyuyu1 is offline   Reply With Quote
Old 12-26-2010, 09:27 PM   #22
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

No problem at all.
Danthurs is offline   Reply With Quote
Old 12-27-2010, 03:31 PM   #23
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2008
Posts: 90
Thanks: 0
Thanked 2 Times in 1 Post
Richardyuyu1 is on a distinguished road
Default

I tested each wire at the PCM for continuity and each one tested ok. So now what do I do? My first guess is maybe the EGR isn't getting enough voltage to open? I figured that I would ask you guys for any more ideas while I have the PCM open.


98 SLE
Richardyuyu1 is offline   Reply With Quote
Old 12-27-2010, 03:47 PM   #24
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

You can test the wires on either end of the EGR plug for voltage. The solenoid will open with 9v, that'* how I test the solenoid. If you put a wire from a 9v battery to the outside terminals you should hear the solenoid click.
Danthurs is offline   Reply With Quote
Old 12-27-2010, 04:11 PM   #25
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2008
Posts: 90
Thanks: 0
Thanked 2 Times in 1 Post
Richardyuyu1 is on a distinguished road
Default

I tested the egr again and it'* opening fine, I'm guessing the egr isn't getting enough voltage to open for some reason.
Richardyuyu1 is offline   Reply With Quote
Old 12-27-2010, 04:26 PM   #26
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

The FSM says to check the EGR valve for signs of excessive heat. If so, could be a clogged cat. Also mentions checking the MAP sensor, this can cause all kinds of funny problems.
Danthurs is offline   Reply With Quote
Old 12-27-2010, 05:30 PM   #27
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2008
Posts: 90
Thanks: 0
Thanked 2 Times in 1 Post
Richardyuyu1 is on a distinguished road
Default

I did notice when I took the EGR out to clean it that there is a crack in what I think is the heat shield towards the bottom of the EGR. And part of the plastic body has also broken off. But it'* the ring at the very top of the EGR so I don't think it has affected the performance at all. And the engine light used to come on and turn off once a day, but since I changed my plugs 4 weeks ago the light has only come on twice.
Richardyuyu1 is offline   Reply With Quote
Old 12-27-2010, 06:22 PM   #28
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Could you post up a picture of this? A crack in the EGR is a vacuum leak.
Danthurs is offline   Reply With Quote
Old 12-28-2010, 12:58 PM   #29
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2008
Posts: 90
Thanks: 0
Thanked 2 Times in 1 Post
Richardyuyu1 is on a distinguished road
Default

Here are the pics of what I think is a cracked heat shield on the EGR. Last night I tested the wires after I reconnected the pcm and only one wire had any kind of voltage and it is one of the gray wires,specifically one of the two wires at the very ends of the plug(the other being the yellow wire). I tested that wire to the black ground wire and not only did I have voltage but it also activated what I think is the IAC on the throttle body. No other wires had any voltage. The crack is between the plastic upper-body the lower metal base of the EGR.
Attached Thumbnails
2 o2 sensors?-egr-pics-002.jpg   2 o2 sensors?-egr-pics-003.jpg  
Richardyuyu1 is offline   Reply With Quote
Old 12-28-2010, 01:03 PM   #30
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Does the solenoid move?
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Whats the deal with BOSCH o2 sensors? anthonyv62 1992-1999 3 06-07-2003 12:48 AM
how many O2 sensors in a Series I? 93-SSEI- General GM Chat 18 03-06-2003 06:00 AM
Bosch O2 sensors.. the low down?? delta88 1992-1999 8 03-01-2003 04:24 PM
New Techinfo Topic - O2 sensors willwren 1992-1999 6 02-07-2003 03:48 PM
O2 sensors Dylansdad 1992-1999 1 11-04-2002 11:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.