1997 SSEi idle issue - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-14-2015, 08:38 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2010
Posts: 77
Thanked 0 Times in 0 Posts
tyrael2304 is on a distinguished road
Default 1997 SSEi idle issue

My 97 ssei dies intermittently at low rpms. Usually when I go to park or stop at a light. I replaced the tps not too long ago. I'm thinking the IAC valve? I had my car scanned and it says the tps. But I just replaced it. I've disconnected the battery and what not. Do I need to hook it up to a scanner and clear the code?
tyrael2304 is offline   Reply With Quote
Old 01-14-2015, 11:41 PM   #2
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

What do you mean it says the TPS? Are you getting a code? If so, what code?
Mike is offline   Reply With Quote
Old 01-15-2015, 01:34 AM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2010
Posts: 77
Thanked 0 Times in 0 Posts
tyrael2304 is on a distinguished road
Default

It gave auto zone code p0121. Which is for the tps. I replaced it less than 2000 miles ago. When ever I let off the gas it stumbles. If I rev it in short bursts it drops to 500 rpms. I'm not getting a light for the idle air control valve but it seems the most likely culprit. I'm not feeling any hesitation while accelerating. The other day I started it up and it revved to 2500 rpm. I also unplugged the IAC with the car on and the idle didn't change at all.
tyrael2304 is offline   Reply With Quote
Old 01-15-2015, 08:46 AM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

the code means the circuit is intermittent, there could be a bad plug at the sensor or pcm, or wiring between them.
jwfirebird is offline   Reply With Quote
Old 01-15-2015, 09:19 AM   #5
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Did you install the new TPS like how I done it in this video?


Mike is offline   Reply With Quote
The Following User Says Thank You to Mike For This Useful Post:
Soft Ride (01-15-2015)
Old 01-15-2015, 04:53 PM   #6
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2010
Posts: 77
Thanked 0 Times in 0 Posts
tyrael2304 is on a distinguished road
Default

I believe I did. I spoke with you before I replaced it. I'll check as soon as my wife gets home
tyrael2304 is offline   Reply With Quote
Old 01-16-2015, 09:14 AM   #7
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2010
Posts: 77
Thanked 0 Times in 0 Posts
tyrael2304 is on a distinguished road
Default

OK. I reinstalled it just to be safe. My main question is how do I clear the code? I've heard you can't just unhook the battery in my car? Is it possible that because the code was never cleared that it could be acting as though its faulty?
tyrael2304 is offline   Reply With Quote
Old 01-16-2015, 09:16 AM   #8
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

You need a scantool to clear the code.
Mike is offline   Reply With Quote
Old 01-16-2015, 10:12 AM   #9
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2010
Posts: 77
Thanked 0 Times in 0 Posts
tyrael2304 is on a distinguished road
Default

Do you think it could be causing it to act faulty if it hasn't been cleared? It only recently started dying. Its been showing the code for a while
tyrael2304 is offline   Reply With Quote
Old 01-16-2015, 01:16 PM   #10
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

if its acting funny there is still something wrong, like the plugs or wiring
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1997 Buick LeSabre P0300 and P1406 with rough idle ymmot04 Buick 9 03-24-2014 08:28 AM
1997 Upper intake manifold issue 3800 vernonh76 1992-1999 12 04-21-2008 09:04 AM
1997 Bonneville SSE High Idle got2bee3 1992-1999 2 10-06-2007 12:15 PM
1997 Buick PArk Ave/1997 Bonneville tranny swap ?'s OLBlueEyesBonne General GM Chat 2 02-04-2005 01:11 PM
Decisions, 1997 Aurora or 1997 Riviera 89ssebonne90 Bonneville GXP/ Northstar Powered Cars 22 03-17-2004 10:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.