1996 SSEi Questions PLEASE HELP - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-21-2003, 10:39 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Aug 2003
Location: Raleigh NC
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
wesley1959 is on a distinguished road
Default 1996 SSEi Questions PLEASE HELP

Ok Guys. I hope I can get some help here. I purchased a 1996 SSEi with 146K miles on Monday. This car is a 1 owner and I have every maintanance record since it was purchased. Oil changes etc... You would think that this was a new car by the look outside and inside. HOWEVER here are some problems I have noticed.
1 - The temp gage almost always reads the next click over 200. I am not used to seeing such high temps is this BAD.
2 - When I checked the coolant there is some oil in it. Not much but some. Should I have the heads checked?
3 - The Low Coolant light and the Low Washer Light comes on constantly then will go off whenever it desires. The coolant and the washer fluid isnt low. What gives? Is there some kind of sensor going bad?
4 - The SuperCharger makes a slight bearing noise but I have been told that this is standard with most SuperChargers. Can I get this noise to stop without replacing it?
5 - How many miles should I expect to get on this engine as it has been well maintained. It has been using Mobil 1 for 3 years and 28K miles. Should I stay with this oil also?
6 - General question on the gauges. When you start the car are the gauges suppose to cycle over all the way to the right, Then come back all they way to the left then go to thier positions per thier feedback?

Thanks for all your help in advance.
Wes
wesley1959 is offline   Reply With Quote
Old 08-21-2003, 10:53 AM   #2
Junior Member
 
Join Date: May 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
SSEi95 is on a distinguished road
Default Re: 1996 SSEi Questions PLEASE HELP

Quote:
Originally Posted by wesley1959
1 - The temp gage almost always reads the next click over 200. I am not used to seeing such high temps is this BAD.
With a stock thermostat 200* is normal. Since heat is one of your engines enemies I would highly recomend installing a 180* thermostat in place of the 195* stock one. Many of us here have them and it has helped out alot.

Quote:
Originally Posted by wesley1959
4 - The SuperCharger makes a slight bearing noise but I have been told that this is standard with most SuperChargers. Can I get this noise to stop without replacing it?
This might be your coupler inside the SC. If you take the belt off the SC try to spin the pulley. If you feel a little play in it chances are you need a new coupler. Yes, the supercharges do make a distinctive sound but depending on the sound the coupler could be the cause as well.

Quote:
Originally Posted by wesley1959
6 - General question on the gauges. When you start the car are the gauges suppose to cycle over all the way to the right, Then come back all they way to the left then go to thier positions per thier feedback?
The gauges are supposed to do this. I'm not sure if you remember the old Pontiac commercials on tv but they showed the gauges doing just that at the end of them all. Personally I like the way the turn on. I think it looks pretty cool.

...and for the rest of your questions I am sure someone will step up soon and give you an answer. Oh, and welcome to the club!
SSEi95 is offline   Reply With Quote
Old 08-21-2003, 04:15 PM   #3
Senior Member
Posts like a Turbo
 
Join Date: Sep 2002
Location: sterling heights michigan
Posts: 495
Thanks: 0
Thanked 0 Times in 0 Posts
BUBBA is on a distinguished road
Default temp

i had same concerns about temp when i got my 96 ssei. put in a 180 stat and it runs cooler but still goes up to 220 in traffic. its normal. the computer wont turn on the fans until 220 degrees. i will be going back to 195 stat before winter though, i want good heat in the middle of winter.
BUBBA is offline   Reply With Quote
Old 08-22-2003, 04:32 PM   #4
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

There are coolant and washer fluid level sensors. Sounds like both of them may be dirty. I would try to clean both of them.
fuddyduddy121 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Intake Manifold Gasket Advice Needed 2003 SSEi Pics Questions Help Please dancssei 2000-2005 5 08-29-2011 09:21 PM
1996 bonnie ssei supercharger is rattling please help tpulliam79 Forced Induction 82 04-10-2008 11:21 PM
Part # help for 1996 please Boreas 1992-1999 9 11-04-2006 12:33 AM
Questions,Questions,Questions.......... dbeast420 Lounge 2 05-06-2006 03:49 AM
Questions questions questions big_boss2010 1992-1999 2 09-06-2003 01:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:16 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.