1995 Park Avenue Ultra issues - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-29-2012, 08:45 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default 1995 Park Avenue Ultra issues

Hello, I just bought a 1995 Park Avenue Ultra, for $1000 has 196k, decent shape, it runs great. But im experiencing a plethera of issues. I bought it about an hour and 20 mins from home, drove it home on the interstate no issue, but now its giving me hell. Im experiencing a severe power loss and the transmission wont kickdown into a lower gear say to pass or anything. I replaced the vacuum cannister and the modulator on the front of the tranny from a junkyard car and it seemed to help then it did it again or rather didnt downshift on command. Also it seems like it has low power, when i first got it it was great i was happy as could be. Now it just doesnt seem to have that pep in its step. Ive only had it a week and have had alot of things pop up and ive addressed them such as new ac compressor, burned crank sensor wire (had to put in new pigtail connector) it locked me out of itself (not the doors) it tripped the anti theft, had to do the resistor trick to imitate the resistor in the key. If anyone has any suggestions on the no kickdown please let me know, Thanks.
Mr Fix It is offline   Reply With Quote
Old 07-29-2012, 10:23 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

is it the sc engine? any codes? check fuel pressure? look at normal maint. stuff see if the fuel filter, air filter, plugs, wires have been changed recently?
jwfirebird is offline   Reply With Quote
Old 07-30-2012, 02:36 AM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

Yes it is supercharged. It has a check engine light on. Has brand new ac Delco plugs and new wires with maybe 200 miles on them. Guy I bought it from put a cold air filter system on it and it looks like its brand new. I don't know about the fuel filter. It seems that when cold it does downshift but warm it won't.
Mr Fix It is offline   Reply With Quote
Old 07-30-2012, 05:56 AM   #4
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Check/Clean MAF sensor. This involves removing it and spraying it with a cleaner that is SAFE for MAF sensors.

Then check your TPS sensor.
https://www.gmforum.com/trouble-shoo...sensor-279319/
Mike is offline   Reply With Quote
Old 07-30-2012, 07:31 AM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

pretty much guessing until you read the code for check engine light
jwfirebird is offline   Reply With Quote
Old 07-30-2012, 08:39 PM   #6
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Yup, get that scanned. More than likely dealer only unless you know someone that can scan OBD1.5 and 2.0. Autozone can't touch the 1.5'*.
Mike is offline   Reply With Quote
Old 07-31-2012, 02:27 PM   #7
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

What is the maximum boost you are getting at WOT?
2kg4u is offline   Reply With Quote
Old 07-31-2012, 02:57 PM   #8
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

My uncle has a Snap On scanner that reads OBD 1.5, past history codes are prndl switch failure, tps high, and qdm 1 failure. When he was looking at it it was working just fine, now its not working again. I replaced the tps with one off my brothers Bonneville SSE old engine that blew up. no change, the tps was reading weird on the scan tool, it seemed jumpy, i did clean the MAF sensor with MAF cleaner. No change. It has a mind of its own, sometimes it works as it should and downshifts and i can pass, but most of the time it wont it just boggs when i step on it. I dont have a boost gauge in this car to see how much its putting out at WOT
Mr Fix It is offline   Reply With Quote
Old 07-31-2012, 03:28 PM   #9
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

I also forgot to mention that when it acts up my overdrive does NOT kick in, it shifts up to third and then stays there. If that helps at all?
Mr Fix It is offline   Reply With Quote
Old 07-31-2012, 03:58 PM   #10
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

you take out the plug for the trans check it out and reseat it. qdm is ussually a wiring issue with the pcm'* power circuit for sensors and that
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 Park Avenue Ultra suspension Problems? Mr Fix It Buick 5 10-20-2012 02:42 AM
New guy, 1995 Buick Park Ave Ultra w issues Generic1 Buick 6 09-22-2012 11:01 PM
1995 park avenue ultra chris00gtp Performance, Brainstorming & Tuning 4 12-18-2005 01:40 AM
late 90's Park Avenue Ultra vs. 2000 SSEi dbtk2 General GM Chat 2 08-14-2003 02:15 AM
Putting a 1993 Park Avenue Ultra trans in my 1994 SLE??? OLBlueEyesBonne Performance, Brainstorming & Tuning 1 03-27-2003 12:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.