1992 bonneville death - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-22-2007, 04:23 PM   #1
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2007
Location: hickory nc
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
biggun2079 is on a distinguished road
Default 1992 bonneville death

Hi, i hope somebody here can help. i just bought a 92 bonneville it has the 3.8 ltr. supercharged 3800 motor, when i got it it was missing and popping i changed the plugs (put in bosh platnium +4) ran great for about 10 miles then the insutruments started going haywire and finally quit and so did the car, i can crank it and it will idle (rough) but if i try to "give it gas" it starts really popping and then shuts down. I'm thinking maybe alternator? or is there another part i need to be looking at? any help would be greatly appreciated..

also my brother says its burning rich from what he can see.
biggun2079 is offline   Reply With Quote
Old 01-22-2007, 04:25 PM   #2
Junior Member
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

Check your battery cables at all contacts. Peel back the protective cover on the battery side of the cables, check for corrosion and clean if needed.


Oh and pull the Platinum plugs out, throw them away and get AC delco or NGK plugs They are highly discouraged in forced induction engines.
Bonneville92V688 is offline   Reply With Quote
Old 01-22-2007, 04:26 PM   #3
Member
Posts like a V-Tak
 
Join Date: Jun 2006
Location: Wood River, IL
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Soulmonger is on a distinguished road
Default

First thing you should do is replace the spark plugs. Our cars don't like bosch and they dont like platinum.

Where does this popping noise come from? Could possibly be the cat. converter is clogged. Especially if its running rich. o2 sensor possibly out too.
Soulmonger is offline   Reply With Quote
Old 01-22-2007, 05:24 PM   #4
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2007
Location: hickory nc
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
biggun2079 is on a distinguished road
Default

thanks guys ill do that, but would that cause the gauge to act up like that before it died?
biggun2079 is offline   Reply With Quote
Old 01-22-2007, 05:28 PM   #5
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

the instrument clusters on those year bonnies are known to go wild like that.. usually from corrosion on the connectors on the back...

a full tuneup is probably in order...

plugs
wires
fuel filter
air filter
pcv valve
etc...
harofreak00 is offline   Reply With Quote
Old 01-22-2007, 07:21 PM   #6
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

biggun...if you need some help with the car, im Over in Fayetteville NC
1993 SLE is offline   Reply With Quote
Old 01-22-2007, 07:48 PM   #7
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2007
Location: hickory nc
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
biggun2079 is on a distinguished road
Default

i cleaned the battery cables, nothing changed, the popping sounds like its starving for air or gas i cant tell which but the exhaust smells very rich can an o2 sensor cause this, and instruments going dead? or could it be the brain (whatever thats called lol) btw thanks for your input guys im not giving up on her yet!

1993sle thanks for the offer but i cant even get it home right now im having it towed in the morning.
biggun2079 is offline   Reply With Quote
Old 01-23-2007, 09:11 AM   #8
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2007
Location: hickory nc
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
biggun2079 is on a distinguished road
Default

does anyone know about the security system? can it be bypassed someone told me this could cause the symptoms i have. just wondering. thanks
biggun2079 is offline   Reply With Quote
Old 01-23-2007, 09:20 AM   #9
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,643
Thanked 997 Times in 774 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Quote:
Originally Posted by biggun2079
does anyone know about the security system? can it be bypassed someone told me this could cause the symptoms i have. just wondering. thanks
VATS disables the starter. No pass key, no start.

What have you done as far as what Haro has said...tune up?

After the engine dies, turn the key to OFF, then turn back to the ON position, do you hear the fuel pump prime?
If not,
Do power windows and locks work?
Mike is offline   Reply With Quote
Old 01-23-2007, 09:29 AM   #10
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2007
Location: hickory nc
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
biggun2079 is on a distinguished road
Default

i havent replaced the o2 sensor yet but i did the rest, still no gauges working not even the compass or driver info panel, or rpm gauge, oil pressure, boost meter,or temp gauge.
yes you can hear the fuel pump when ignition is in the on position, it starts fine but after a few minutes it starts choking and dies, if you touch the gas pedal before that it dies quicker. and the power door locks and windows work fine.
biggun2079 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The Bonneville Is Painted 56k MEGA DEATH **UPDATE 4-25-07** K-OtiK Your Ride: GM Pictures & Videos 49 04-30-2007 07:41 AM
Bonneville accident causes death vital49 General GM Chat 11 01-27-2006 12:17 PM
The death of the Bonneville. Here's your chance to tell GM. willwren General GM Chat 33 10-05-2005 03:44 PM
GM Confirms Death Of Bonneville CFoote General GM Chat 16 02-06-2005 09:29 PM
Death of a Bonne ASDadam General GM Chat 4 12-31-1969 08:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:46 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.