[b]1997 crank case vacuum / won't stay running[/b] - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-22-2007, 05:03 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2007
Location: Wilkes-barre,PA
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
chompy1234 is on a distinguished road
Default [b]1997 crank case vacuum / won't stay running[/b]

Ok i'm a newbie here, Let start at the beginning, I had to replace the UIM due to coolant loss. I caught it BEFORE the engine hydrolocked!! which was a good thing, that was a year ago. After replacing the UIM DTC p0171 was set, and remains until this day.Then a couple months ago we had a cold snap and the temps outside was below zero. The car sat over the weekend and when I started it to go to work I hear a CRACKING noise coming from the front of the engine. I popped the hood and removed that stupid plastic cover from the top of the engine to see where the cracking noise was coming from. (the cracking noise sounded like plastic breaking) when I removed the oil filler cap and extenstion tube it made a sucking noise and the idle changed and the cracking noise stopped and never came back. Now since then if I were to remove the oil filler cap there is a STRONG vacuum. I was driving the car into work and it just died, I had it towed to my house and it will start idle and die, the more pedal (gas) I give it the more it boggs down then backfires carries on then dies. I'm about to pull my hair out.. please help.

Here is what I have replaced so far....
UIM and gaskets,
LIM gaskets
Head gaskets (what the heck I had everything else apart)
EGR Vavle
MAF,MAP, TPS, IAC, Temp sensors
Starter
Oil sending unit
Fuel pump and filter
Just did a complete tune up on it last week.

HELP HELP HELP.. need this car to get to work. have a loaner right now but got to give it back soon
chompy1234 is offline   Reply With Quote
Old 02-22-2007, 05:11 PM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Okey dokey. Double check your PCV and o rings that are supposed to seal it. That'* the #1 cause of a sucking oil cap.

On the P0171... you are possibly in luck. Remove your battery cables and inspect them....ensure you remove the rubber boots after pulling out the bolts. There'* nearly 95% chance that you have corrosion and the poor connections (I know..everything else is fine) is causing your P0171. I'm a Lean Bank One survivor... it nearly cost me a 5 gallon can of gas and a match to figure out what was causing that code.
BillBoost37 is offline   Reply With Quote
Old 02-22-2007, 05:58 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2007
Location: Wilkes-barre,PA
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
chompy1234 is on a distinguished road
Default

I'll check the battery cables when I get home. thanks that code might cost me the 5 gallons LOL. I will check the PCV also. My last question / problem that would need to be solved if the PCV vavle doesn't solve it would be the stalling/ can't stay running problem.
chompy1234 is offline   Reply With Quote
Old 02-22-2007, 05:59 PM   #4
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2007
Location: Wilkes-barre,PA
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
chompy1234 is on a distinguished road
Default

forgot.. there are no other codes set.. only the front bank lean... thank in advance
chompy1234 is offline   Reply With Quote
Old 02-22-2007, 06:11 PM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

The missing PCV o-ring is your issue. Fix that, come back happy.
willwren is offline   Reply With Quote
Old 02-22-2007, 08:22 PM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2007
Location: Wilkes-barre,PA
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
chompy1234 is on a distinguished road
Default

yup that fixed my extreme vacuum in the crank case. also fixed my dtc... but it still won't run.. its like its running out of gas.. I bought a cheapy fuel pressure gause from harbor frieght and it reads 10 - 15 psi not good from what i read on all data diy.. junky advance parts... you think it might be my fuel pump or did i break something while driving around with out the proper pvc ?? let me know

thanks

john
chompy1234 is offline   Reply With Quote
Old 02-22-2007, 09:01 PM   #7
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

We need to know if it improves with the vacuum line removed from the FPR. Does that fuel pressure bleed off quickly? Or did it hold at that pressure after you shut it off?
willwren is offline   Reply With Quote
Old 02-22-2007, 10:38 PM   #8
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2007
Location: Wilkes-barre,PA
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
chompy1234 is on a distinguished road
Default

bleeds off in less then a minute, and i didn't check the FPR because I forgot to mention I just canged it also. I know that doesn't mean much but I don't think that is the problem. since I am now in bed I'll check it tomorrow. I'm going to just throw this out there.. I disconnected the fuel line from the filter and rigged up the output hose to a gas can and dangerously turned the key on for the fuel pump to prime the line and the fuel just trickled out (like 10 psi.. not a forceful rush) and I had my wife try to start it and the same volume of fuel came out.. (a trickle not a rush) so I am assuming the fuel pump. Oh before I get a lecture I know it was dangerous but I'm at my wits end with this poor running car..

I will add however. thats for the other replies.. all my other problems are fixed. The only good news it I have dropped this tank three times before to fix the sending unit, the original pump, then the gaske was leaking.. so I think I'm and ace at it or just an arse..
chompy1234 is offline   Reply With Quote
Old 02-22-2007, 10:42 PM   #9
Junior Member
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

Hmm, sounds like the new fuel pump is slowly taking a crap. The fuel should come out kinda hard. Did you use a ACDelco pump, or a cheapy?
Bonneville92V688 is offline   Reply With Quote
Old 02-22-2007, 10:50 PM   #10
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2007
Location: Wilkes-barre,PA
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
chompy1234 is on a distinguished road
Default

cheap junk from advance auto.. go figure
chompy1234 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Car won't stay running this cold morning. ymmot04 2000-2005 2 12-11-2009 05:39 PM
2000 Bonnie won't stay running ceg 2000-2005 7 07-29-2009 08:08 PM
1997 Bonneville won't stay running mdalpias 1992-1999 8 06-14-2009 02:54 AM
Car Won't stay running Xac Xado 2000-2005 4 02-23-2006 08:03 PM
Interior lights on my 1997 SE won't stay off ... help! jhammer22 1992-1999 0 07-20-2003 12:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.