well finally got the bonneville fixed! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-02-2006, 03:25 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2006
Location: Irmo,SC
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
twisted89SE is on a distinguished road
Default well finally got the bonneville fixed!

hey everyone....well after getting back from vacation we worked on the 89 some more...and we replaced the ICM,ECM,Coils and still no fire...so we took it up to our buddies shop and it was the crank sensor!!....apparently the crank pulley had warped and it made the crank vibrate somewhat a broke the sensor...soo when it broke just died. Lucky, it was in my driveway.....hate computer controlled...
twisted89SE is offline   Reply With Quote
Old 08-03-2006, 12:27 PM   #2
Senior Member
True Car Nut
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default

Good to hear you got it fixed, but sorry it cost you a trip to the shop. Unfortunately, the crank sensor can and does go sometimes... :(
lash is offline   Reply With Quote
Old 08-04-2006, 11:21 AM   #3
Senior Member
True Car Nut
 
Join Date: Mar 2004
Location: Ames, Iowa
Posts: 3,066
Thanks: 0
Thanked 1 Time in 1 Post
bill buttermore is on a distinguished road
Default

If the harmonic balancer took out the crank sensor, I presume you installed a new harmonic balancer too?
bill buttermore is offline   Reply With Quote
Old 08-04-2006, 03:57 PM   #4
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default sensor

something could have fallen down in there when the motor was running. There is no plastic guard on our cars. Mine failed when the belt slipped off due to a bad water pump bearing.
SSEBONNE4EVA is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
well we got it fixed Idunno 1992-1999 1 11-20-2006 09:31 PM
Finally got My 95 se Fuel problem fixed phoenix116354 1992-1999 1 05-23-2005 12:09 PM
Well Well Well ratmfan2118 Lounge 30 05-23-2004 01:34 PM
finally got it fixed LittleHoov General GM Chat 3 09-15-2003 10:37 PM
Finally got my car fixed Mayhem_3 General GM Chat 1 04-05-2003 04:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:18 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.