SES Light On After Repair - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-02-2006, 07:38 PM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
WankerWeasel is on a distinguished road
Default SES Light On After Repair

My gas milage went to almost 1/2 what it had been before and the car was stalling a bit so I brought it in and had the codes pulled. At the time the SES light was on most of the time but it went off from time to time and didn't come on til you had driven a lil. They found that the MAF was bad, o2 sensor was totally dead, and the spark plugs likley needed to be replaced. I put in a new used MAF and new o2 sensor this weekend. Unhooked the negative ground for over an hour to clear the computer. The car drives fine now and the gas milage is back up but the SES light stays on all the time now. It'* on right when I start the car up and doesn't go off even for a min like it did before. I know everyone will say I need to pull the codes and I'll get around to it sometime soon here, I just want people'* guesses at what else it may be. So, what do you think?
WankerWeasel is offline   Reply With Quote
Old 02-02-2006, 07:42 PM   #2
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

Lets just hope you don't have a code 41...

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 02-02-2006, 09:03 PM   #3
jdq
Senior Member
Posts like a Corvette
 
Join Date: Nov 2005
Location: Hamilton, Ontario , Canada
Posts: 1,201
Thanks: 0
Thanked 0 Times in 0 Posts
jdq is on a distinguished road
Default

If your plugs likely need changed I would do plugs and wires , it might not get rid of SES but if they arent good it probably will help with mileage. Also put your year and trim in your sig ,you could probably pull your code with a paperclip.
jdq is offline   Reply With Quote
Old 02-04-2006, 11:17 AM   #4
Senior Member
Posts like a Turbo
 
Join Date: May 2005
Location: Fredericton, New Brunswick.
Posts: 380
Thanks: 0
Thanked 1 Time in 1 Post
Timothy's Buick is on a distinguished road
Default

Go to Technifo, and find the article about pulling codes off the light.
You can do this yourself, just jump terminals a and b on the ALDC (assembly line diagnostic connector.) Code 12 will flash, 1 blink, short pause, 2 blinks. Long pause and the code will repeat itself. Lets indeed hope you don't have a code 41, that was a PITA to repair! Involved pulling the timing cover, dropping the oilpan, and what a PITA! But, its fixed, and garunteed for another 100,000 kms!
Timothy's Buick is offline   Reply With Quote
Old 02-09-2006, 04:14 PM   #5
Junior Member
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
wjcollier07 is on a distinguished road
Default

ok, now see this is scary, THIS IS THE EXACT PROBLEM i had last year, everything the same, EVERYTHING, i replaced my MAF cause it was bad, and the o2 because it was worn out and then the plugs and a couple other things, and TO THIS DAY that BRIGHT ORANGE SES light is on, it is THE MOST ANNOYING THING EVER, please, someone help, i want it off too, help out the SES people in need.

Update: All fixed...no problems anymore
wjcollier07 is offline   Reply With Quote
Old 02-09-2006, 04:20 PM   #6
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Quote:
Originally Posted by wjcollier07
ok, now see this is scary, THIS IS THE EXACT PROBLEM i had last year, everything the same, EVERYTHING, i replaced my MAF cause it was bad, and the o2 because it was worn out and then the plugs and a couple other things, and TO THIS DAY that BRIGHT ORANGE SES light is on, it is THE MOST ANNOYING THING EVER, please, someone help, i want it off too, help out the SES people in need.
Hang onto your shorts WJ..we'll get this one fixed up. Please follow along and pull your codes as well. Report back and pray you don't have code 41...cause Don seems to indicate it'* BAD
BillBoost37 is offline   Reply With Quote
Old 02-09-2006, 05:53 PM   #7
Senior Member
True Car Nut
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default

Code 41 = Cam sensor circuit

PITA to fix, but doable.
lash is offline   Reply With Quote
Old 02-19-2006, 10:04 PM   #8
Junior Member
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
wjcollier07 is on a distinguished road
Default code

well i was told to repost with my code, and my code is 22 and i know that means TPS voltage too low but it is set PERFECTLY

You need to know what the ECM is seeing from the TPS sensor, so we can rule out the TPS and wiring as well as the ECM... These older 3800'* nedd the TPS for load and fuel calibration.. If the ECM thinks the voltage is too low than there may be an issue with the TPS... Have you ever replaced it?
wjcollier07 is offline   Reply With Quote
Old 02-21-2006, 10:23 PM   #9
Junior Member
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
wjcollier07 is on a distinguished road
Default Update

well today i set my mind to fixing this dang car, totally sick and tired of that light. So i sat down and thought about what could be causing that code. Well it turns out that the TPS i bought from Advance Auto Parts has been defective the whole time!!! i put the old one back in and now the car is PERFECT AGAIN!!! EXPLAIN THAT. The only thing is that it won't reach WOT, it only reaches 4.33v for WOT, and for idle i have it set at .44. The ECM doesnt seem to mind, so, i don't know what to say, just thought i would post that
wjcollier07 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Self Repair vs Auto Repair SHop? Car still at Casino.... nat1ve 1992-1999 2 08-27-2006 04:53 PM
ses light. making me mad buzzbomber88le 1987-1991 5 05-01-2003 10:20 PM
SES light comes on when i coast. 93-SSEI- 1992-1999 3 04-23-2003 12:31 AM
SES light SSEi95 General GM Chat 9 03-23-2003 11:18 PM
Rough tranny shift & SES Light illumination dsmorse 1992-1999 4 01-09-2003 02:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.