My Bonne need help. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Closed Thread
 
 
 
Thread Tools Search this Thread
Old 02-23-2005, 11:43 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2005
Location: Brampton, Ontario
Posts: 3,014
Thanks: 0
Thanked 0 Times in 0 Posts
Maymybonnieliveforevr is on a distinguished road
Default My Bonne need help.

Hi Everyone, I have been following these posts for awhile but now I have a problem which I could really really use some advice. I have a 90 SSE in which I replaced the starter with a rebuilt myself. It started twice but wouldn't start from then on, I can't hear the fuel pump when I turn on the ignition, and disconnect one of the feed lines close to injectors and saw no pressure. I checked the fuse behind the glove box and there is power there ( meaning the fuse is ok). I had the fuel pump repaced by a service center about 5 years ago. Does anyone know where or if there is a relay for the electric fuel pump.Please tell there is and hopefully thats the only problem cause I really miss and need my bonne. I'm sure others can relate. If I have to replace the pump I will but as a last resort since it'* veeeeeeeeery cold out. Thanks for any help.

PS. By the way it'* white with 453,536 Km. My Baby..........sniff sniff .. I miss her deeplyand I can't let here go.
Maymybonnieliveforevr is offline  
Old 02-23-2005, 11:49 PM   #2
Senior Member
Certified Car Nut
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

In 92 the pump relay is right above the fuses behind the glove box. Can't tell you which one, they seemed to move them around a lot.
J Wikoff is offline  
Old 02-24-2005, 12:14 AM   #3
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2005
Location: Brampton, Ontario
Posts: 3,014
Thanks: 0
Thanked 0 Times in 0 Posts
Maymybonnieliveforevr is on a distinguished road
Default

Quote:
Originally Posted by jwikoff99
In 92 the pump relay is right above the fuses behind the glove box. Can't tell you which one, they seemed to move them around a lot.
Thanks jwikoff99. Just above the fuse panel behind the glove box are ten 1" black relays. Two vertical rows of five per row with one larger one at the very top (makes it eleven). I switched the ten fuses but it made no difference. I wish I knew which one it was. I have the Echlin Component Locator Guide and it states that for a 90/91 3.8L (VIN C) Port Fuel Injection, there is a "fuel pump test connector" behind the battery. Does anyone have any idea what it'* for or how it can help me with this situation? I have spark to #1 cylinder so I'm assuming it must be the fuel pump since I don't hear the 3-4 second hum when I turn the ignition on. Is it possible I did something when I replaced the starter? It turns over fine although I'm starting to wear down my battery.
Maymybonnieliveforevr is offline  
Old 02-24-2005, 12:26 AM   #4
Senior Member
Certified Car Nut
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

Take a foot or two of large wire and connect the positive terminal of your battery to the fuel pump test terminal. Does it kick in? If not, it'* a good chance it'* the relay. If you take the relay out, short terminals 1 and 4 together, and it still doesn't start, it'* the pump.
J Wikoff is offline  
Old 02-24-2005, 01:02 AM   #5
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2005
Location: Brampton, Ontario
Posts: 3,014
Thanks: 0
Thanked 0 Times in 0 Posts
Maymybonnieliveforevr is on a distinguished road
Default

Quote:
Originally Posted by jwikoff99
Take a foot or two of large wire and connect the positive terminal of your battery to the fuel pump test terminal. Does it kick in? If not, it'* a good chance it'* the relay. If you take the relay out, short terminals 1 and 4 together, and it still doesn't start, it'* the pump.
thanks for the info. It'* midnight here now. I'll have to look at it tomorrow. Does anyone have any idea which of those black relays behind the glove box are for the fuel pump? ten are the same size, the one at the very top is larger.

Thanks jwikoff99. I'll get back to you tomorrow and let you know how I made out.
Maymybonnieliveforevr is offline  
Old 02-24-2005, 01:17 PM   #6
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2005
Location: Brampton, Ontario
Posts: 3,014
Thanks: 0
Thanked 0 Times in 0 Posts
Maymybonnieliveforevr is on a distinguished road
Default

I want to make a correction by saying that there are only 4 (not 5) black relays and one larger one at the top behind the glove box. I checked the 8 relays and found that they were all identical, the terminals were labeled 30,85,86,87 & 87. The two that made contact were 30 & 87 on all of them. on the larger one, terminals 1B & 5 as well as 2 & 4 made contact. As for the Fuel Pump Test Terminal, there were 2 behind the battery one green and one blue I put power to both with ignition on and off and heard no pump. I had to put a battery charger on, since the engine wouldn't turn over ( just clicking ). By the way I tested the Pump Terminal with the battery charger on. I really don't want to drop the tank unless I have to because it sure is cold out and with the slight slop in my driveway I don't have the strength to push it in the garage.

PS. I think my Bonne is upset with me, cause I said afew bad words after I installed the rebuilt starter and i wouldn't start after the 3rd try. I should have left it running after the 2nd . Bonne..... I promise I'll wash and vacuum you if you start this weekend....Promise!
Maymybonnieliveforevr is offline  
Old 02-24-2005, 02:20 PM   #7
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default Re: My Bonne need help.

Quote:
Originally Posted by Maymybonneliveforever
PS. By the way it'* white with 453,536 Km.
how many miles is that???
1993 SLE is offline  
Old 02-24-2005, 02:29 PM   #8
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default Re: My Bonne need help.

Quote:
Originally Posted by 1993 SLE
Quote:
Originally Posted by Maymybonneliveforever
PS. By the way it'* white with 453,536 Km.
how many miles is that???
453 536 kilometers = 281 814.205 miles

harofreak00 is offline  
Old 02-24-2005, 02:56 PM   #9
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default Re: My Bonne need help.

Quote:
Originally Posted by harofreak00
Quote:
Originally Posted by 1993 SLE
Quote:
Originally Posted by Maymybonneliveforever
PS. By the way it'* white with 453,536 Km.
how many miles is that???
453 536 kilometers = 281 814.205 miles

ok thanks wow that is alot of miles


back to your regualar scheduled program
1993 SLE is offline  
Old 02-24-2005, 02:57 PM   #10
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2005
Location: Brampton, Ontario
Posts: 3,014
Thanks: 0
Thanked 0 Times in 0 Posts
Maymybonnieliveforevr is on a distinguished road
Default

I want to make a correction to my last post, there are 8 relays not 4. I should have said 4 rows totalling 8. And the mileage is correct, thanks harofreak00.
Maymybonnieliveforevr is offline  
 
 
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
Need some help finding trim for my new bonne prevch General GM Chat 28 05-15-2005 10:33 PM
Sorry it's not a bonne, but i need help! alec_b 1992-1999 9 04-22-2005 04:02 PM
Need a pic of a bonne (read), help please! TMoney General GM Chat 11 04-08-2005 12:32 AM
Need help, 2000 bonne trans codes.. need answer!!! caminated2k Lounge 3 02-09-2005 10:59 PM
BONNE vs. BONNE?? bonnie94ssei General GM Chat 18 06-21-2003 10:46 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:42 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.