Just got a 90 SSE - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-06-2006, 01:12 AM   #1
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Jan 2006
Location: Edmonton, Alberta, Canada
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
Cyric78 is on a distinguished road
Default Just got a 90 SSE

Hello, my name is Mike. I am a first time poster, short time reader.. lol..

Well, I just got a 1990 Bonneville SSE just after Christmas.. My 89 Taurus died an evil and nasty tranny death after many, many highway km'*..

This is my first GM.. I am a Ford man personally, but I couldn't be picky when picking up a new vehicle, since I was 600k from home, and on a tight budget. I called a close friend and asked if he knew anyone selling a car for a couple hundred bucks... and so I bought the SSE for $500, with 260k on it. The engine is very strong, but slightly lacking in low-end torque.

The major issues that I need to address on the car is the radiator fans do not work, and the previous ownder tried to jerry-rig it to run all the time.. I'm assuming that the temp sensor for the fans failed, so I need to know where the sensor is located and if possible some pics of how the wiring should look going into the sensor, and to the fans, so I can repair that properly.

Another thing that he played with was some of the under dash wiring, which I know won't be a problem once I look at it (constant power was run to the whole instrment cluster, ergo battery would die all the time.. it helps if you don't run constant power to a switched circuit which powers the compas, DIC, seat controls, and heater).

Does anyone know why the in-car heater would blow lots of hot air for 10-15 mins of driving, then start blowing colder air? I keep the temp set at 20 C, which it heats to, then it seems to let the temp drop to what feels like 16C.. I hope its not the heater core...

Ok, more yet (yes, I have lots more.... ).. Why would the SES light come on when I'm driving, but not when idling? It comes on after 2-3 mins of driving, and goes off after 2-3 mins of idling... I know I need to pull the codes for the computer, which I will do this weeking, along with pics..

Other things that I need info on, but is not that troublesome to me is things like the air-ride suspension, and I have intermittant steering wheel controls (seems like a dirty/flaky contact).

Oh, and one other thing that bothers me, and I'm thinking its a vacuum leak.. when I accelerate, I hear a hissing sound, and it gets louder the harder I accelerate, and varies with the rpm.. am I right about it being a vacuum leak?

And now to the good things about the car .. All the body trim is there, except for the grill (long story for another post), and one body skirt infront of the passenger rear wheel. All the lenses are intact, and working except the fog lams, and its only the lenses that are broken. There is only 3 little spots of rust, which is amazing for a car from Alberta. The original hood pad is still there with the SSE on it, and it has gold trim, including the wire-esque wheels, with only one lug cover missing..

If you have any questions or comments (or flames for being a FORD man) please reply, and I will respond accordingly!

Thanks everyone!
Cyric78 is offline   Reply With Quote
Old 01-06-2006, 01:21 AM   #2
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

welcome... we have a resident ford man here already... u two will bond
harofreak00 is offline   Reply With Quote
Old 01-06-2006, 02:22 AM   #3
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Jan 2006
Location: Edmonton, Alberta, Canada
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
Cyric78 is on a distinguished road
Default

Well, like I said, I've been reading around, and I noticed there was another Ford man here.. so I don't feel *SO* bad for owning a Chevy...
Cyric78 is offline   Reply With Quote
Old 01-06-2006, 02:45 AM   #4
Senior Member
Posts like a Corvette
 
Join Date: Jun 2005
Location: Berkeley, IL
Posts: 1,596
Thanks: 0
Thanked 0 Times in 0 Posts
DarkShadow is on a distinguished road
Default

okay, your temp sensors are located on the engine block under the throttle body and a little back, theyre hard to get to, just warning you.

as for the heater, im not familiar with C temps, but if in F thats not 90, for example if you have it set at 85f it will heat the car up to 85 then try and blend the air to get it a little cooler so it dosent over heat it past 85. but if you have it set at 90 which is the max btw, it will just keep heating and heating and heating till youre sweating in your seat.

the SES light on our cars is retarded, in fact the whole diagnostic system is retarded, it wont pick up some things and throw a **** fit for others, but i believe an intermittant one is probably an oxygen sensor or similar sensor, if it is the o2 GET AN ACDELCO unit, nothing else will work right. a good source for gm parts (including acdelco) is gmpartsdirect.com or rockauto.com

now for your "vacuum" problem. check all the vacuum hoses in the engine compartment for leaks, if you dont find any, another sopund producing problem is a clogged or a partially restricted catalytic converter. if it is the cat it would explain your power loss with the low end torque, these motors have butloads of torque so theres definately a problem with it.
DarkShadow is offline   Reply With Quote
Old 01-06-2006, 12:35 PM   #5
Senior Member
True Car Nut
 
Join Date: Jul 2003
Location: Toronto, Ontario, Canada
Posts: 5,158
Thanks: 0
Thanked 0 Times in 0 Posts
repinS is on a distinguished road
Default Re: Just got a 90 SSE

Quote:
Originally Posted by Cyric78
And now to the good things about the car .. All the body trim is there, except for the grill (long story for another post), and one body skirt infront of the passenger rear wheel. All the lenses are intact, and working except the fog lams, and its only the lenses that are broken. There is only 3 little spots of rust, which is amazing for a car from Alberta. The original hood pad is still there with the SSE on it, and it has gold trim, including the wire-esque wheels, with only one lug cover missing..
damn. You just described my car down to a T in the state that it was in when I got it. Is it black also?

Typically though, I treat the electronic climate control as if it were the conventional kind. Crank the temp/fan up to max, let it heat and heat and heat, and then turn it down once I'm feeling okay...
repinS is offline   Reply With Quote
Old 01-06-2006, 09:15 PM   #6
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Jan 2006
Location: Edmonton, Alberta, Canada
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
Cyric78 is on a distinguished road
Default

Well, I'm starting to think that my vacuum leak is an exhaust leak, at the manifold... shouldn't be an issue... I'll figure it out tommorow and sunday, along with some pics.. I think this car might have some potential...

As for the colour of my car, its white, with gold trim, including the gold 'wire' wheels... the classic late 80'*/early 90'* looking car... lol...

On a side note.. pulled into the parking lot today after work, and what'* parked behind me? A burgandy 89-91 SSE... lol.. funny how you notice the same model of car more when you get a new one..
Cyric78 is offline   Reply With Quote
Old 01-07-2006, 11:27 PM   #7
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: GTA, ON, Canada
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Mike G is on a distinguished road
Default

As for the colour of my car, its white, with gold trim, including the gold 'wire' wheels... the classic late 80'*/early 90'* looking car... lol...

Sounds like mine when I first got it. I was missing 2 of those center caps though. I've had two of these cars- I should be able to help you with a lot of your issues.

I've also got lots of parts for 88-91 SSE'*, lots being mainly cosmetic as well as many of the computers and assorted chips. I have about 6 grills- so if you need one- im sure that somthing could be worked out.

Does your compass and DIC work?
Mike G is offline   Reply With Quote
Old 01-08-2006, 02:31 AM   #8
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Jan 2006
Location: Edmonton, Alberta, Canada
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
Cyric78 is on a distinguished road
Default

Yeah, my compass and DIC work perfect... I just need to check to see if my headlight washers work... is there supposed to be a wiper for them? (I'm assuming not...) One thing I noticed about your car Mike G is that you don't have a lugage rack on the trunk deck... mine does unfortunatly...

About the only things that aren't working on my car is the power seats (although I can *make* them work), my power door locks aren't working (I can hear something click, but nothing locks/unlocks), and the air ride suspension...
Cyric78 is offline   Reply With Quote
Old 01-08-2006, 02:41 AM   #9
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: GTA, ON, Canada
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Mike G is on a distinguished road
Default

My god would I love to play with your car! I love fixing all the anoying things that don't work. You have a luggage rack on your trunk? I'd like to see a pic of that. I've never seen an SSE with that on it. What color is your interior? but if your SES light is on its most likly an air sensor, like another member had mentionend. The headlight washers don't work (anymore) on most of the SSE'* I've seen. The plastic is too thin around the mounting bar for the tank, and it cracks and all the fluid leaks out. As far as your doors not opening, been there done that. I've replaced a total of about 20 latches on different H bodies (including La sabre and delta 88. its a bad design where all the dirt and oil gathers in the mechanism. have any pics?
Mike G is offline   Reply With Quote
Old 01-08-2006, 03:27 AM   #10
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Jan 2006
Location: Edmonton, Alberta, Canada
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
Cyric78 is on a distinguished road
Default

The doors do open, its just the power locks won't move... my interior is grey leather, in rather rough shape, but nothing that seat covers won't fix..

Here'* some pics of my rough, dirty bonnie.. (The previous owner didn't take any care of her...)



Yup.. up close she looks a little rough, but in reality, its all minor cosmetic, except the grill (story for later)


The bad purple tint is going away tommorow... LOL


There are only 3 small spots of rust on the car that I've seen so far, this one which is behind the drivers rear wheel, the same on the passenger side, and the rear passenger door has a rust line starting to show from where the metal was rolled over for the skin...


Yup, gotta replace the drivers side flasher, and do the general maintenence...



Yes, I am parked in a south-west direction...
Cyric78 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
just got a new 1996 bonneville SSE ZZZZaaacck Performance, Brainstorming & Tuning 4 11-18-2007 01:51 AM
Difference in the 97 40th sse and the regular sse? showshocka2k General GM Chat 6 03-18-2007 02:56 PM
98 SSE Intermittent Random Stalling- just about got creamed Satchmo 1992-1999 6 11-18-2003 11:32 PM
i got the 1994 sse so what now and is 200 hp easy????? rwe62382 1992-1999 4 04-01-2003 12:59 AM
1990 Bonneville SSE Just Got it! shortstuf212559 1987-1991 4 12-22-2002 03:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:44 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.