help pulled codes from car. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-19-2011, 03:01 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Aug 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
bbell101584 is on a distinguished road
Default help pulled codes from car.

Have a 1990 Bonneville le pulled codes and got 24 27 28 29 and 31. 24 is vss but the speedometer works. 31 is park neutral switch I think and the car starts in park. Wondering if maybe ecm bad all seem to be transmission free but transmission feels fine any help would be appreciated thanks.
bbell101584 is offline   Reply With Quote
Old 06-19-2011, 11:08 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

24 vehicle speed (vss) sensor circuit fault
27 quad-driver module (computer) 2nd gear circuit
28 quad-driver module (computer) circuit #2 fault
29 quad driver module (computer) 4th gear circuit
31 cam position sensor fault

so the car is running fine and you got all these codes?

i would be looking for wires shorted to ground on the engine wiring harness, especially the harness that goes to the trans
jwfirebird is offline   Reply With Quote
Old 06-19-2011, 11:43 AM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Aug 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
bbell101584 is on a distinguished road
Default

Yea car runs fine took the transmission vacuum modulator off this morning transmission fluid came out replaced with a new one. Replaced a few air line couplings that were dry rotted. Unplugged the wire harness from the transmission cleaned it added dielectric grease. Reset so no codes took car for drive going though all gears came home checked for codes and there were none. I don't know something I will keep monitoring the situation the next couple of days to see if codes come back.
bbell101584 is offline   Reply With Quote
Old 06-19-2011, 11:45 AM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

keep us posted
jwfirebird is offline   Reply With Quote
Old 06-23-2011, 09:28 AM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Aug 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
bbell101584 is on a distinguished road
Default

OK got code 31 again. What'* the differnce between code 31 cam position sensor fault and code 41 came sensor. I've read a bunch of threads with people with code 41 for cam sensor.
bbell101584 is offline   Reply With Quote
Old 06-23-2011, 07:24 PM   #6
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

41 is listed as the circuit fault and 31 is listed as sensor fault
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I have some codes pulled on my car ssesc93 1992-1999 5 05-19-2005 02:06 PM
Just Pulled Codes beckstyle 1992-1999 13 03-09-2005 01:07 AM
I just pulled some more codes on my car. ssesc93 General GM Chat 15 01-25-2005 09:05 PM
Pulled Codes... ECM problems? 1994ta 1992-1999 5 12-17-2004 03:21 PM
I pulled the trouble codes and this is what I got! Str8pimpin 1992-1999 2 10-03-2004 12:33 PM


Tags
brian 90 bonneville le

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.