Help! Issues with '91 Bonneville. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-13-2006, 02:46 AM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2004
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Steilhand is on a distinguished road
Default Help! Issues with '91 Bonneville.

Hello all,
Ive had my car for quite some time (1991 Bonneville SSE), and it has a few issues id like to address but dont quite know where to start. Ill list the things im looking for and if anyone has any ideas, id be grateful.
1)The driver side rearview mirror is broken, ive been unable to locate any replacements, does anyone know of any place that sells them?
2)The button in the center console with the musical note on it will not stay in one spot, it constantly tries to turn itself off, ive had to jam a piece of paper into it to get it to stay on, does anyone else have this problem?
3)The high beam indicator in the dash does not work, I do not know if it is a bulb issue, the only way for me to tell if im on highbeams or low beams (other than flicking from high to low) is to look at the yellow light on the sunroof switch, which turns on and off in correspondence with the high/low settings.
4)Fog lights are broken, cant find replacements.
5)The black grid/mesh material that should cover the tail lights has been broken in several places, and I cannot find a source for a replacement.
6)Windows are very slow to go up or down in the front, fine in the back, I assume this indicates I need new motors?
7)Leaking trunk, with no apparent holes in the gasket around it, and no holes in the trunk lid itself, I assume ill have to lie in there with a flashlight and get someone to spray it with water to ascertain the problem, unless anyone else has seen this before and has a solution.
Weirdest problem, the radio does not turn on when I push its power button, it just randomly kicks in after about 5 minutes of driving, I can get it to turn on sooner by holding down the EJECT button on the tape player, I dont get it.
9)High pitched whistling sound when turning left occasionally.
10)Car has a tendency to pull to the right hand side of the road, even though I recently had a tire alignment.

There are other tiny issues with it that im not terribly concerned with, but those are the major ones. If anyone has any ideas or knows of an explanation for any of this, please share. Im not very knowledgeable about vehicles, but I rather like this car and id like to see it remain in good condition for a while longer
Steilhand is offline   Reply With Quote
Old 06-13-2006, 09:50 AM   #2
Senior Member
True Car Nut
 
Join Date: May 2002
Posts: 2,936
Thanks: 0
Thanked 0 Times in 0 Posts
sse1990 is on a distinguished road
Default

I'll try and help here


1. For the mirror I would try some salvage yards

2.For that button, I have had to take mine apart and removed the spring inside it to let the button stay in the on position all the time.

3. The high beam indicator, it could either be the bulb OR, do your DRL work? ( daytime Running Lights). I removed my DRL module and put it in my other car and since then the high beam indicator does not function.

4. For the fog lights, I was able to reuse the front cover and back piece and went to an auto parts store and found cheap driving lights that were made the same. Took a bit to rebuild them but it worked. You can put any kind of light there and use the factory wiring, but I doubt that the factory wiring has the same connection, so you will have to make that work.

5. You will have to try and find other taillights, try ebay, they come up on there once and a while

6. Windows are slow on both my cars, they still work so I have left them alone, but yes are known to slow down

7.It may not be the trunk lid or the seal, pull the carpet back in the trunk and inspect the rear strut towers, you may have a leak in the wheel well.

8.Tape player, no clue, sounds like a loose connection inside the radio

9. Could be a bad wheel bearing, but may not be

10. You had a front en alignment? It could be that they did it wrong, OR it could be the brake pads on the right hand side grabbing the rotor or some other front end issue.
sse1990 is offline   Reply With Quote
Old 06-13-2006, 02:50 PM   #3
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: GTA, ON, Canada
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Mike G is on a distinguished road
Default

I would have to agree with Mike for most of the issues that you are having, and most of these problems are quite common, and are easy fixes.
With regard to the gain control- I have gone through several of these, and once the switch does not stay down, its the micro switch itself that is broken. Ive taken a few of them apart, and the little spring just flies out, then its useless.

The trunk leak- Im guessing is a hole in the wheel well, or a rust hole in the trunk somewhere.. The trunk seal dosn't usually leak itself- unless its torn. Im actually in the process of fixing this myself. I have a Tiny hole in the seam. I hastely sealed the trunk a few years ago- but I missed a spot.

I had one of my factory radios do that exact problem that you described. Replace the unit- pretty cheap- Usually about $20.

If you want SSE tails- be prepaired to pay a premium for them.

Where are you located ?
Mike G is offline   Reply With Quote
Old 06-13-2006, 10:58 PM   #4
Senior Member
True Car Nut
 
Join Date: May 2002
Posts: 2,936
Thanks: 0
Thanked 0 Times in 0 Posts
sse1990 is on a distinguished road
Default

Quote:
Originally Posted by Mike G
its the micro switch itself that is broken. Ive taken a few of them apart, and the little spring just flies out, then its useless.

I took the switch apart in the white car when it stopped staying down, seen how it worked, and removed the spring. I don't think I had to do anything else to the switch since it was then able to stay down and kept contact. I did the same thing to the grey car too, since it had a piece of paper wedged to hold it down.
sse1990 is offline   Reply With Quote
Old 06-14-2006, 01:58 AM   #5
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: GTA, ON, Canada
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Mike G is on a distinguished road
Default

Interesting- the ones that I have had- the switch was NFG- not able to hold it down at all. I hate that gain switch- when it works- its good- but when its broken or detoriated....
Mike G is offline   Reply With Quote
Old 06-14-2006, 02:06 AM   #6
Senior Member
True Car Nut
 
Join Date: May 2002
Posts: 2,936
Thanks: 0
Thanked 0 Times in 0 Posts
sse1990 is on a distinguished road
Default

I didn't take any pics of it, but I took it completely apart, removed the spring that pops the button up, so the button stays down, and it works fine. Except the light is burnt in it. Actually come to think of it, I don't think I fixed the one in the Grey car yet. I had the one in the white car and I picked up a spare.

Maybe I will just yank the one out of the white car and put it on the Grey one, considering we may be raping the white car of it'* AC to fix the Grey one.
sse1990 is offline   Reply With Quote
Old 06-14-2006, 12:26 PM   #7
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: GTA, ON, Canada
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Mike G is on a distinguished road
Default

Quote:
Originally Posted by sse1990
I didn't take any pics of it, but I took it completely apart, removed the spring that pops the button up, so the button stays down, and it works fine. Except the light is burnt in it. Actually come to think of it, I don't think I fixed the one in the Grey car yet. I had the one in the white car and I picked up a spare.

Maybe I will just yank the one out of the white car and put it on the Grey one, considering we may be raping the white car of it'* AC to fix the Grey one.
Sounds like the white cars days are numbered....
I've always hated the design of that gain control switch. either the switch itself wont stay down, or the vinyl that covers the switch cracks and comes off. What a stupid design.
Mike G is offline   Reply With Quote
Old 06-14-2006, 10:16 PM   #8
Senior Member
True Car Nut
 
Join Date: May 2002
Posts: 2,936
Thanks: 0
Thanked 0 Times in 0 Posts
sse1990 is on a distinguished road
Default

Yeah, plates are up for renewal in a few weeks, not sure if I am gonna renew them. If I don't then I have to transfer them to the Grey car. SO I can keep the personal plates.
sse1990 is offline   Reply With Quote
Old 06-14-2006, 11:24 PM   #9
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: GTA, ON, Canada
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Mike G is on a distinguished road
Default

Quote:
Originally Posted by sse1990
Yeah, plates are up for renewal in a few weeks, not sure if I am gonna renew them. If I don't then I have to transfer them to the Grey car. SO I can keep the personal plates.
If they're personal Mike- put them on the grey car......
Mike G is offline   Reply With Quote
Old 06-14-2006, 11:44 PM   #10
Senior Member
True Car Nut
 
Join Date: May 2002
Posts: 2,936
Thanks: 0
Thanked 0 Times in 0 Posts
sse1990 is on a distinguished road
Default

That is the plan, just deciding if I wanna keep 3 cars on the road. I guess it depends how much we need to steal from it.
sse1990 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
92 bonneville ssei Boost and PCM issues, please help. 92L67Bonnie 1992-1999 2 02-20-2009 12:40 PM
1995 Bonneville repair issues. Need some help, please. surveyor 1992-1999 6 06-12-2007 05:08 PM
bonneville vs. lesabre issues: long with pics...help plz nicklikesmilk 1992-1999 9 04-08-2007 03:27 AM
Electrical Issues PLease help. junior5480 1992-1999 1 11-07-2004 10:02 PM
2 issues I need help with Jrios 2000-2005 3 01-31-2003 06:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.