*&$@in' CAR!!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-04-2003, 10:55 AM   #1
Senior Member
Expert Gearhead
Thread Starter
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default *&[email protected]' CAR!!!

ARRGGHHH...

OK...breathe.....just when I say that the car is running top notch lately, no problems at all, I get into the car this morning to battle the freezing rain and ice pellets we got last night, to find that my trip meter doesn't work anymore.

Because of this my odometer doesn't work, so, after punching away at my trip clock area, it would spring to life spin away like it should, but it gets stuck at 9...for some reason the trip meter won't go past 9!!!

I hit the reset push button, pushed it down, held it, whatever, the meter won't go past 9, so, my drive to work today was just over 0.9 km...grrrrr its a 25 #$(*#$ kilometer drive!!!!

I use that trip meter religiously, I use it for my fuel consumption because the gas gage is less then releiable at the best of times.

Any ideas on what to do, I'm takin it in this afternoon, but some feedback here first would be nice, so that I have something to take to them

Oh and top it off, after I reset the meter for like the 13th time....it started counting backwards...0000 to 9999 to stuck...wacky piece of analog **it

Time to look for a new car....
Jim W is offline   Reply With Quote
Old 04-04-2003, 01:53 PM   #2
Senior Member
Posts like a Camaro
 
Join Date: Jan 2003
Location: Jenison, MI (Near Grand Rapids)
Posts: 1,070
Thanks: 0
Thanked 0 Times in 0 Posts
theJMFC is on a distinguished road
Default

Hey now, some of us don't even HAVE a trip odometer... :(

Is it possible that it'* just dirty or sticking? Maybe it just needs a good cleaning. Aside from that, no clue. Sorry.

Of course, if you're going to sell it...
theJMFC is offline   Reply With Quote
Old 04-04-2003, 02:02 PM   #3
Senior Member
Expert Gearhead
Thread Starter
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

I just got off the phone with my local GM partsman and he was suprised to hear that the odometer doesn't work either....hmmm

He told me, that it could be one or more of the following

1. The trip clock is hooked up via a cable to the trans, it could be that the cable is bad.
2. The connection to the gage or dash is gone bad
3. The connections are dirty

The problem is, the little wheel dealie gear get to 9 and stops, I sure the cable is OK, but...the dash cluster itself, there must be something wrong up in there I suppose the dash will have to come off and they may have to look in there to see. He told me one hour to get in there and diagnose the problem. Fixing it is another story (depending on what the problem is)

I'll be actively searching for a new car from here on in, it looks like the real estate market is far to hot for my bare ***, so the condo may have to wait Hmmmm, several people want to buy my car....this could be interesting....
Jim W is offline   Reply With Quote
Old 04-04-2003, 02:16 PM   #4
Senior Member
Posts like a Camaro
 
Join Date: Jan 2003
Location: Jenison, MI (Near Grand Rapids)
Posts: 1,070
Thanks: 0
Thanked 0 Times in 0 Posts
theJMFC is on a distinguished road
Default

I doubt I could afford your beauty, but I do wish I could. My days of unlimited funds are long gone.

Still, I say fix it. A newer car is no guarantee of less problems. I would know (stupid freeking '96 GA [two wheel bearings, two abs sensors, one radiator, starter, coolant sensor - in the 11 months i've owned it!] ).
theJMFC is offline   Reply With Quote
Old 04-04-2003, 02:26 PM   #5
Senior Member
Expert Gearhead
Thread Starter
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

You're right Jon

Its worth fixing. I have been pretty diligent in saving up the money so it might be worth it to have a look and try and get it fixed. Its hard when you get so used to having something work and then one day it doesn't work.

I'm hoping its just some gremlin in there and a some warm weather and a good cleaning of the dash will fix the problem.

If not I will have to watch my gas gage like a hawk and just fill it up at 3/4 of a tank, now that I cannot rely on my trip meter anymore. I had it down to a science, 450km, I had 9 litres left...LOL...good times...
Jim W is offline   Reply With Quote
Old 04-04-2003, 02:45 PM   #6
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

It sounds like the mechanical elements to the meter inside the instrument panel have gone bad.
fuddyduddy121 is offline   Reply With Quote
Old 04-04-2003, 06:42 PM   #7
Senior Member
Expert Gearhead
Thread Starter
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

Idiot lights...LOL...nice one..

I just have the systems monitor on the far right hand side, it shows the car in plan view and indicates things like battery, oil, coolant etc. Nothing to fancy pants.

However, since this afternoon I have looked into this issue furthur. Our local dealer, who are scam artists to the max...told me that I would have to spent $375 plus tax to get a new cluster and it has to be Ministry of Transportation approved and supplied from a special shop who deal only in odometer/trip clock repair. Then they need another $200 buck so that they can take an hour and 10 mins to install the damn thing.

I went to a local transmission shop to ask it if is the cable. He said he'd have to take a look but its minor to fix if it is the cable.

Now Don? you said the trip clock is not hooked up via cable, so, how is it hooked up? I have the old school analog rolodex style. Its not hooked up to the PCM like in newer cars?

Then my mom told me that hers died for a day or so about a week ago, then it came back to life. Chalk it up to Ford to psyche you out like that..

Oh, ya one final thing...maybe I mentioned it already. The odometer is kaput too..it must be hooked up to the trip meter. If I don't get it fixed, I'll never be able to sell the car.
Jim W is offline   Reply With Quote
Old 04-04-2003, 09:43 PM   #8
Senior Member
Posts like a Corvette
 
Ol' Timer's Avatar
 
Join Date: Oct 2002
Location: New Jersey - Most of Our Elected Officials Have Not Been Indicted
Posts: 1,483
Thanks: 0
Thanked 0 Times in 0 Posts
Ol' Timer is on a distinguished road
Default

Quote:
I hit the reset push button, pushed it down, held it, whatever, the meter won't go past 9
Well, it'* nice to know I have a relative that has the exact same problem as my orphan. The only difference is when mine reaches 9 tenths of a mile it will "click-click-click" as if it'* trying to go that extra mile but it never gets there. Sometimes when I hit the reset button it will just stay at zero and not move at all, but when I hit it just right it works perfectly. I agree that something is @#$% up with the meter and you may just as well live with it. Of course you could try hitting it with a larger hammer!!!
Ol' Timer is offline   Reply With Quote
Old 04-04-2003, 09:50 PM   #9
Senior Member
Posts like a Northstar
 
Join Date: Sep 2002
Location: Riverton, Wyoming
Posts: 740
Thanks: 0
Thanked 0 Times in 0 Posts
egladman is on a distinguished road
Default

what'* a trip odometer? lol

oh yeah i forgot mine isn't fancy enough to have one.
egladman is offline   Reply With Quote
Old 04-04-2003, 10:22 PM   #10
Senior Member
Expert Gearhead
Thread Starter
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

The speedometer and tach works no problemo at all. Its hard to understand. If I get one from the wrecker who will install it? Anywhere I have gone, they have been particularly difficult with doing this repair. Something about fiddling with odometers and how the government doesn't really like that.

The main kilometre counter is dead too... its like the trip ticker is workin (or not working) in conjunction with the odometer. Is that normal?
Jim W is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Im Not Sure>>>>>>^*&(&(&(& Cookseytonyc 1992-1999 4 08-19-2009 06:59 PM
&%(*#(#($&Y^&#&$*(%(^%)%^) willwren Lounge 24 10-11-2007 06:56 PM
$&)$&*)#&+()#%& )#@(%&#)%*(&+_ Maymybonnieliveforevr Lounge 6 05-02-2007 07:07 PM
mom & hailey, mom & kim, mom & kim & mom harofreak00 Lounge 6 04-09-2007 03:40 PM
&$#&%$& Curse Sol General GM Chat 44 01-19-2004 01:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:07 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.