HELP!!! please - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > GM Technical Discussion and Questions > General GM Chat

General GM Chat Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

LinkBack Thread Tools Search this Thread
Old 11-03-2003, 11:55 AM   #11
Senior Member
Certified Car Nut
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default DAMN!

the silverstar website has the wrong the bulb that the web says is 885 and the light is actually 880 DAMN i got all confused

thanks to everyone
1993 SLE is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
ANYBODY please, please help, car alarm driving me NUTS aodessey 1987-1991 17 11-29-2008 01:05 PM
Please, please PLEASE! willwren Lounge 20 03-26-2008 12:16 PM
HELP HELP HELP, EXPERTS PLEASE !! statusplease 1992-1999 8 03-15-2008 05:49 PM
ELECTRICAL PROBLEMS< PLEASE HELP, PLEASE jamesdean26hfx 1992-1999 3 09-20-2004 06:45 PM
The WP is driving me crazy, please....oh...please help me! valerka 1992-1999 2 07-28-2004 10:15 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:55 PM.