my brakes broke... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1987-1991

1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 12-25-2003, 07:30 PM   #1
Senior Member
Posts like a Camaro
Join Date: Oct 2003
Location: Hamilton, Ontario
Posts: 1,074
Thanks: 0
Thanked 0 Times in 0 Posts
phoenix_flame220 is on a distinguished road
Default my brakes broke...

As I was on my way to the mall for christmas shopping, my ABS and emergency brake lights come on and stay lit up. After about 5 minutes of the lights being on, the brake pedal goes hard and then goes to the floor! No power brakes! Good thing i was in a parking lot when it happened. So after a few minutes of playing with the pedal, both lights go out and the brakes go back to normal. So i continue on cautiously. Then the lights ABS andf emergency lights come on again. 5 minutes later the brakes die again. This happened 3 times while I was out. I dont want t drive the car like this in the winter. what would cause this? And what would it cost to fix?
"-@--------@--" 1990 SSE " Black Ice " 220,000+ kms, GX3, sunroof

16" Streetwear Diablo wheels | Blazer Fog Lamps | Silverstar 9005 low beams | Mesh Grille | STB | '94 Top end | Delco Type 2 Ignition | Blue interior LEDs | LED 3rd brake light | Auto-dimming rear view mirror | Pioneer DEH-P7600MP | Rockford 5 1/4 Components and 6x9s
Daily driver : '95 Buick Regal Custom | Blue under dash LEDs | Infinity 5 1/4 components | 8 Inch sub under dash | 12 inch Bazooka sub in trunk | Rockford 4 ch amp | Trunk mounted EQ | Pulsing trunk LEDs
phoenix_flame220 is offline   Reply With Quote
Old 12-25-2003, 09:56 PM   #2
Senior Member
Posts like a Camaro
padgett's Avatar
Join Date: Jul 2003
Location: Orlando, Florida
Posts: 872
Thanks: 0
Thanked 0 Times in 0 Posts
padgett is on a distinguished road

Am assuming you have a TEVES since posting here. First thought (and about the cheapest) is the boost pump relay ($12) not closing when it should. This lets the pressure drop low which turns the red light on and when the red is on, so is the yellow.

That said if the accumulator were good, you should have up to 20 stops after that before the boost goes away so probably need one of them also ($100).

Just my thoughts from very limited information (your service manual should have a complete decription and diagnosis in section 5).

Note: few GM servicemen understand the TEVES since it is German and GM only used for a few years (basically 88-90),. If must go to a dealer, try a VW or SAAB center.
Padgett, 0 Sirius
padgett is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Serptentine Belt Broke Today throb 1992-1999 28 10-18-2009 01:22 AM
Lost power brakes after slamming on brakes maxpower9004 1992-1999 22 12-08-2007 12:52 PM
Broke in the '03 at the track today... Rotgut Performance, Brainstorming & Tuning 17 05-18-2003 01:56 AM
Brakes Brakes Brakes Terran 2000-2005 11 04-27-2003 10:28 PM
Broke Motor Mount!! READ vols1992 1992-1999 2 12-19-2002 12:45 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:06 PM.