GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat - View Profile: jimmy544

jimmy544 is on a distinguished road
Posts like a V-Tak

jimmy544 jimmy544 is offline

Member

About Me

  • About jimmy544
    Biography
    Retired engineer
    Location
    Metro Boston
    Interests
    ham radio cars
    Occupation
    retired
    First Name
    jim
    Year of your GM
    1994
    Make
    Buick
    Model
    Le Sabre
    Engine Type
    3800 V6
    Color
    Arctic White
    Modifications
    Royal Purple power steering fluid. Bosch alternator.

Statistics

Total Posts
Visitor Messages
Total Likes
General Information
  • Last Activity: 09-28-2015 01:39 AM
  • Join Date: 06-15-2013

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. 08-06-2015 08:06 PM - permalink
    I am having some other problems with the 1994 Buick LeSabre. I have looked at many post and threads and have not seen anything about paint sort of peeling or popping off the car. I have seen cars of this era and earlier from the big three makers with large areas of missing paint. The undercoat seems very good but the paint is coming off a little bit all of the time. But the strange thing is that the paint that is still on does not come off easily.
    Does someone have a good trick for removing the paint that is left?? This car is in good shape for its years and I would like to get the old paint that is left off of the car so it can be repainted.
  2. 06-15-2013 03:32 PM - permalink
    Hi to all this is my first post. I have a 1994 Buick Le Sabre. It runs well except for a developing problem with Service Engine Light and is progressively more difficult to start in cold weather. Sometimes we see 30+ mpg onthe highway at 70. I have replaced all fluids, filters(except trans) spark plugs, wires and o2 sensor, temp sensor, PC valve, battery, alternator, master brake cylinder and a couple of other things. Took it to a shop as the AC was not working well. They found : a bad connection to the engine temperature sensor and a dirty air mass sensor fixed them. They reset all of the codes and said iif the SE light came on again, likely the PROM was bad. The car ran stronger but the SE light came on again. It is still intermittent as it was before. Mileage stayed about the same as before.
    Does anyone know what is the best scanner to get for that year?
    Are there after-market chips to replace the PROM ?
    Can the 1994 be upgraded to 1996 or 1997 standards?

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.