and the saga continues... (low/no oil presure...) - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-12-2008, 02:06 PM   #11
Darrel
Guest
 
Posts: n/a
Default

146,000 or so on the motor...
  Reply With Quote
Old 02-12-2008, 06:10 PM   #12
Darrel
Guest
 
Posts: n/a
Default

got it back now. turns out that the presure was fine all along. the sensor was cracked so i had it replaced but the gauge is still reading wrong. They said that the gauge has gone bad on me. I seem to remember Boosty telling me at one point about being able to replace the circuit board behind that gauge to fix this sort of problem. anyone know anything about this? Thanks.
  Reply With Quote
Old 02-12-2008, 06:25 PM   #13
Senior Member
Posts like a Northstar
 
Join Date: Apr 2007
Location: Edinboro, PA
Posts: 567
Thanks: 0
Thanked 0 Times in 0 Posts
jbmark33 is on a distinguished road
Default

Mine fell out into two pieces when i took mine out.
jbmark33 is offline   Reply With Quote
Old 02-12-2008, 06:28 PM   #14
Senior Member
Certified GM nut
 
Join Date: Jun 2003
Location: Saginaw, MI
Posts: 1,632
Thanks: 0
Thanked 0 Times in 0 Posts
FiReDeViL is on a distinguished road
Default

glad to hear it was a sensor, mine was more foul than that no one could tell me what was wrong so after close to $666 (yea i know.. white curse...) i just gave up lol
FiReDeViL is offline   Reply With Quote
Old 02-12-2008, 07:46 PM   #15
Darrel
Guest
 
Posts: n/a
Default

well it wasn't really the sensor... even though it was cracked it was still sending out the signal correct and the pressure was always correct in the engine. the gauge electronics are where the problem lies. i'm not going to worry about it this winter but come summer i might remove the gauge cluster and try and fix it if i can find out how...
  Reply With Quote
Old 02-12-2008, 09:29 PM   #16
Senior Member
Posts like a Northstar
 
Join Date: Apr 2007
Location: Edinboro, PA
Posts: 567
Thanks: 0
Thanked 0 Times in 0 Posts
jbmark33 is on a distinguished road
Default

Well it'* still good to know it was something stupid rather than your oil pressure actually being low.

Low oil pressure would rank the worst possible mechanical problem in my book.

I would feel lucky if i were you.
jbmark33 is offline   Reply With Quote
Old 02-12-2008, 09:42 PM   #17
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

what did they say your pressure was?
harofreak00 is offline   Reply With Quote
Old 02-12-2008, 11:05 PM   #18
Darrel
Guest
 
Posts: n/a
Default

16-17 at idle while in gear and a steady 50 while driving.
  Reply With Quote
Old 02-12-2008, 11:18 PM   #19
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

sounds pretty low to me. I usually see 30-35 at idle in gear.
harofreak00 is offline   Reply With Quote
Old 02-13-2008, 12:34 AM   #20
Darrel
Guest
 
Posts: n/a
Default

really...


Hmm... i want to get an aftermarket gauge anyhow, so maybe i'll look into that sooner then i planed.
  Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
And the saga continues..detailed wheels and wheel wells SSEimatt93 Your Ride: GM Pictures & Videos 25 05-07-2006 10:28 PM
The Saga Continues beckstyle General GM Chat 9 01-20-2005 06:29 PM
My idle saga continues... Damemorder 1992-1999 4 10-16-2004 01:02 AM
Car won't start, stall, die saga continues rnbraud 1992-1999 35 08-17-2004 12:35 AM
Low Oil Presure websitedude 1992-1999 1 12-09-2002 06:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.