01 Silverado 5.3ltr no start when warm - GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat

Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

01 Silverado 5.3ltr no start when warm

Reply

 
 
 
Old 08-08-2013, 02:31 PM
  #1  
Member
Posts like a V-Tak
Thread Starter
 
CrazyGunner's Avatar
 
Join Date: Jun 2009
Location: Olds
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
CrazyGunner is on a distinguished road
Cool 01 Silverado 5.3ltr no start when warm

this is a heat related issue. the truck will start fine until it gets to operating temp then just dies, no misfire no sputter. and not throwing any codes. it will not start again until engine is cold and starts up fine.
I can only drive about 10 miles then Im hooped or let it sit an Idle for about 30 min then dies and will not start.

things I have done already
new plugs
fuel injector cleaner
new fuel pump
cleaned MAF sensor

any Ideas before I start changing more parts...
CrazyGunner is offline  
Reply With Quote
Old 08-08-2013, 04:06 PM
  #2  
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

crank position sensor.
jwfirebird is offline  
Reply With Quote
Old 08-08-2013, 04:12 PM
  #3  
Member
Posts like a V-Tak
Thread Starter
 
CrazyGunner's Avatar
 
Join Date: Jun 2009
Location: Olds
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
CrazyGunner is on a distinguished road
Default

Originally Posted by jwfirebird View Post
crank position sensor.
Thanks! I give that a shot!
CrazyGunner is offline  
Reply With Quote
Old 08-08-2013, 04:14 PM
  #4  
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

there is a few other things it could be but thats very common and hard to troubleshoot because it works cold
jwfirebird is offline  
Reply With Quote
Old 08-08-2013, 04:16 PM
  #5  
Member
Posts like a V-Tak
Thread Starter
 
CrazyGunner's Avatar
 
Join Date: Jun 2009
Location: Olds
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
CrazyGunner is on a distinguished road
Default

Originally Posted by jwfirebird View Post
there is a few other things it could be but thats very common and hard to troubleshoot because it works cold
ya its a tough one. I was told to try that by someone else aswell but thought Id throw it up on here and see what everyone else thought
CrazyGunner is offline  
Reply With Quote
Old 08-13-2013, 10:36 PM
  #6  
Member
Posts like a V-Tak
Thread Starter
 
CrazyGunner's Avatar
 
Join Date: Jun 2009
Location: Olds
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
CrazyGunner is on a distinguished road
Default

there we go!! changed crank position sensor let it idle until warM and took for a drive good to go!


Thanks Justin
CrazyGunner is offline  
Reply With Quote
Old 08-14-2013, 06:10 AM
  #7  
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

no prob, thanks for the update
jwfirebird is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ROberg
Introductions for new members
3
06-20-2011 09:19 AM
KoryKreisler
Chevrolet
15
07-01-2010 11:39 PM
CJCroel
1992-1999
3
04-10-2008 08:56 PM
L67Silhouette
Oldsmobile
11
09-27-2007 10:57 PM
Roni271
1992-1999
10
05-13-2003 07:19 PM


Thread Tools
Search this Thread
Quick Reply: 01 Silverado 5.3ltr no start when warm


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.