GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat (https://www.gmforum.com/)
-   Chevrolet (https://www.gmforum.com/chevrolet-179/)
-   -   01 Silverado 5.3ltr no start when warm (https://www.gmforum.com/chevrolet-179/01-silverado-5-3ltr-no-start-when-warm-305589/)

CrazyGunner 08-08-2013 03:31 PM

01 Silverado 5.3ltr no start when warm
 
this is a heat related issue. the truck will start fine until it gets to operating temp then just dies, no misfire no sputter. and not throwing any codes. it will not start again until engine is cold and starts up fine.
I can only drive about 10 miles then Im hooped or let it sit an Idle for about 30 min then dies and will not start.

things I have done already
new plugs
fuel injector cleaner
new fuel pump
cleaned MAF sensor

any Ideas before I start changing more parts...

jwfirebird 08-08-2013 05:06 PM

crank position sensor.

CrazyGunner 08-08-2013 05:12 PM

Quote:

Originally Posted by jwfirebird (Post 1584510)
crank position sensor.

Thanks! I give that a shot!

jwfirebird 08-08-2013 05:14 PM

there is a few other things it could be but thats very common and hard to troubleshoot because it works cold

CrazyGunner 08-08-2013 05:16 PM

Quote:

Originally Posted by jwfirebird (Post 1584513)
there is a few other things it could be but thats very common and hard to troubleshoot because it works cold

ya its a tough one. I was told to try that by someone else aswell but thought Id throw it up on here and see what everyone else thought

CrazyGunner 08-13-2013 11:36 PM

there we go!! changed crank position sensor let it idle until warM and took for a drive good to go!


Thanks Justin

jwfirebird 08-14-2013 07:10 AM

no prob, thanks for the update


All times are GMT -4. The time now is 01:28 AM.