GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat (https://www.gmforum.com/)
-   Buick (https://www.gmforum.com/buick-172/)
-   -   Decelerating (https://www.gmforum.com/buick-172/decelerating-308024/)

shawn_s 09-16-2014 10:20 PM

Decelerating
 
My car is decelerating, any one kno why this happens? Or the fix for it?

Tech II 09-16-2014 11:30 PM

Step on the gas pedal?

shawn_s 09-16-2014 11:55 PM

I shouldve explained better, when im driving going up a hill, or say driving anywhere from 20mph to 55-60mph while im still on the gas the car will decelorate.. Not slow down it holds its speed but the RPM's drop! I press down harder and harder and it sluggishly picks up speed, then eventually jumps back to speed when almost to the floor!
It also will pick up speed, if i let off the gas & get back on it & it acts like it should.. Any thoughts!!???

2kg4u 09-17-2014 10:57 AM

Pull the vacuum hose off the fuel pressure regulator and see if you smell gas in the hose. If you do, replace the FPR. Normally I would think you are experiencing a misfire, but you did not mention the check engine light coming on. If the check engine light is coming on, or flashing, you have a different issue.

shawn_s 09-17-2014 01:20 PM

No check engine light.. ill check the fpr line for gas..

shawn_s 09-18-2014 12:47 AM

Nothin in the fpr line, but it looked old, had some kind of green build up on top of it like what comes on the battery post... So i swaped it, & problem is still there

jwfirebird 09-18-2014 08:32 AM

check out your plugs, my inlaws car was kinda doing that when it needed the intake man gaskets done, it was fouling the plugs

shawn_s 09-18-2014 01:30 PM

I gave it a tune up a few days ago, and i bought the car back in febuary i replaced the intake gaskets that night because they were leaking bad.. So it cant be that... Wont hurt pull a couple plugs & check tho

shawn_s 09-24-2014 11:44 AM

Ok, a little update. Read online sumwhere that this could be the "Tcc" in the trans & a way to kno would be that when it does the rpm drop lightly tap on the brake with my left foot and tcc will re ingage and rpms should rise back up.. And sure enough IT DID..
My question now is how many sensors effects this!?
& would changing the speed sensor on the output shaft be a good start?

2kg4u 09-24-2014 12:39 PM

Quote:

Originally Posted by shawn_s (Post 1604873)
Ok, a little update. Read online sumwhere that this could be the "Tcc" in the trans & a way to kno would be that when it does the rpm drop lightly tap on the brake with my left foot and tcc will re ingage and rpms should rise back up.. And sure enough IT DID..
My question now is how many sensors effects this!?
& would changing the speed sensor on the output shaft be a good start?

When you tap on the brake the TCC disengages and the RPM's increase slightly. This is normal operation.


All times are GMT -4. The time now is 08:34 PM.