TOTALLY STUPID!!! SPEAKERS ARE CRAP!!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 08-08-2004, 02:41 PM   #1
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default TOTALLY STUPID!!! SPEAKERS ARE CRAP!!!

I just got back from Best Buy, I had the 350 watt pioneer 4-way 6x9s put in my car. When i turned it on and started listening to it, i was PISSED!!! They produced less bass than stock speakers, wasn't half as clear, were really distorted, and made some crackling noises when i gave it just a little bit of sound. Is this right? Did i waste my money on these speakers? Or did the moron that installed it (thankfully not me) do a bad job and mess up some wiring or something? The installer said that it should have taken him 40 minutes to do it. It ended up taking over and hour, maybe an hour and a half. Please let me know if anybody else has these speakers and if mine are just messed up.

On another note, how much power does the amplifier for the gain control put out? And what is the max power handling on the stock 6x9s? Please let me know quick because im gonna go back and have them fix my friggin speakers soon!
beckstyle is offline   Reply With Quote
Old 08-08-2004, 02:59 PM   #2
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

What sort of head unit do you have? I'd suggest getting AROUND the bose amp, and gain control, by running new wiring. The amp sends out power that'* very different from the industry standard, using weird resistances, and wattages.

They make less bass because they require more power to move as much.
BonneMeMN is offline   Reply With Quote
Old 08-08-2004, 03:05 PM   #3
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

I have the delco system in my car i believe. I have a pioneer DEH-2600 head unit. 50 watts x 4. When i turn the loud(option on head unit) the music just gets distorted and when i turn up the volume it sounds as if the speakers are farting just about. As if they cant handle the power. Are my speakers crap or what?
beckstyle is offline   Reply With Quote
Old 08-08-2004, 03:17 PM   #4
Senior Member
Posts like a Camaro
 
Join Date: Oct 2003
Location: Hamilton, Ontario
Posts: 1,074
Thanks: 0
Thanked 0 Times in 0 Posts
phoenix_flame220 is on a distinguished road
Default

Maybe that farting sound is distortion from your head unit, does it sound like a crunching type of noise?
phoenix_flame220 is offline   Reply With Quote
Old 08-08-2004, 03:26 PM   #5
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

There is constant distortion if i turn up a little. I got at least twice as clear, crisp, music with a HECK of a lot more bass. The noise that the speakers makes is sort of a cracking noise, it makes it durning the music sometimes, and when i turn the radio on and off. Hopefully its not the speakers, if it is the speakers i reccomend all models of it should be thrown into the trash as soon as possible.
beckstyle is offline   Reply With Quote
Old 08-08-2004, 03:38 PM   #6
Senior Member
Posts like a Camaro
 
Join Date: Oct 2003
Location: Hamilton, Ontario
Posts: 1,074
Thanks: 0
Thanked 0 Times in 0 Posts
phoenix_flame220 is on a distinguished road
Default

Does it crackle even when the volume is at lower levels?
phoenix_flame220 is offline   Reply With Quote
Old 08-08-2004, 03:40 PM   #7
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

It does crackle a little bit at low levels but it isnt really noticable.
beckstyle is offline   Reply With Quote
Old 08-08-2004, 04:20 PM   #8
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

I really think with an aftermarket HU and speakers, SSE/i owners need to run new speaker wiring to completely bypass the accessory amp (bose or delco). Otherwise you're amplifying the power 3x, and it'* going up each time.
BonneMeMN is offline   Reply With Quote
Old 08-08-2004, 04:26 PM   #9
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

Well i figured out (or at least think i did) why the music was all crappy and distorted. The friggin MORON that did it at best buy took the wires ( both pairs, one for sub, other for tweeter) and SPLICED, yes spliced them TOGETHER AS ONE! What a moron....... hey, i got an idea. USE A WIRING HARNESS YA MORON! Well im going back to best buy later today and having them fix it. Let me know if im wrong on this so i dont feel as big of a dumbo.
beckstyle is offline   Reply With Quote
Old 08-08-2004, 06:40 PM   #10
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

Quote:
Originally Posted by beckstyle
Well i figured out (or at least think i did) why the music was all crappy and distorted. The friggin MORON that did it at best buy took the wires ( both pairs, one for sub, other for tweeter) and SPLICED, yes spliced them TOGETHER AS ONE! What a moron....... hey, i got an idea. USE A WIRING HARNESS YA MORON! Well im going back to best buy later today and having them fix it. Let me know if im wrong on this so i dont feel as big of a dumbo.
i worked around my stock wiring, and completely rewired it in 12 gauge. it sound really nice with my kenwoods and panasonic. i would tell him to do that
harofreak00 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
stupid, stupid, stupid... petraman Lounge 19 01-29-2008 11:51 PM
AAAAAAAAAHHHHHHHH!!!! Stupid, stupid, stupid!!! BonnieBrougham Lounge 13 04-28-2006 01:00 AM
Mama always said, Stupid is as Stupid Does.... MOS95B Lounge 0 03-10-2004 02:31 AM
Ok, so no idea is stupid, but what about stupid questions..? Mandible Performance, Brainstorming & Tuning 6 12-30-2003 03:41 PM
Freaking Crap Stupid Winter Milage Sol 1992-1999 15 02-13-2003 11:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.