motor/tranny mounts, '92 SSE s/c - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-22-2004, 01:30 PM   #1
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Jan 2002
Location: southern California
Posts: 538
Thanks: 0
Thanked 0 Times in 0 Posts
billha is on a distinguished road
Default motor/tranny mounts, '92 SSE */c

I just discovered that the front driver'* side motor (tranny) mount has separated where the rubber meets the metal bracket nearest to the engine.

How many motor mounts does my engine have?
Do they just bolt-on?
Can anyone tell me the part numbers, cost, and how to replace them?

I doubt that I need to replace the upper torque mount on the passenger side, that one looks ok, but I couldn't even see where the other mounts are. I want to replace all but the torque mounst as soon as possible, but only if they need replacement.

I just called a couple of auto parts stores, and they said there are 4 mounts. There'*
the rubber torque axis mount and the lower fluid mount on the passenger side, and 2 tranny mounts on the driver'* side - the lower front rubber one (mine'* bad) plus the lower rear fluid one.

How can I tell if the fluid mounts need to be replaced? Is it common for only the front driver'* side tranny mount to fail? Have any of you been through this with your Bonnie?
billha is offline   Reply With Quote
Old 03-23-2004, 12:10 PM   #2
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Jan 2002
Location: southern California
Posts: 538
Thanks: 0
Thanked 0 Times in 0 Posts
billha is on a distinguished road
Default

Problem solved.
I called around, including a local Pontiac dealership. The dealer wanted over $300 for the rear tranny mount (driver'* side) so I didn't buy anything from them.
I bought only the front left tranny mount (driver'* side) from auto zone for $39 and had it installed at a local tranny shop. It was completely broken where the rubber meets the metal on the tranny side of the mount. They checked the other tranny mount and the 2 engine mounts and they were all ok.

Interesting note, though - Auto Zone, Kragen, Pep Boys and the Pontiac dealer said that the rear engine mount (passenger side) and rear tranny mount (driver'* side) were fluid filled or something like that...but according to the tranny shop they're not...so everyone I called was wrong about those parts.
billha is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Trans mounts/motor mounts bad? SilverSleeper8704 2000-2005 29 01-06-2011 10:07 PM
Engine/tranny mounts, series II mounts work in series I car? dbtk2 Performance, Brainstorming & Tuning 1 09-11-2008 07:53 AM
motor mounts or tranny mounts laydbaak 1992-1999 8 01-11-2007 10:43 AM
motor mounts and tranny mounts? shrek Performance, Brainstorming & Tuning 10 11-06-2006 10:22 PM
Engine Mounts / Motor Mounts zuluhead 2000-2005 10 11-06-2005 11:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.