Techinfo submissions! - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > GM Technical Discussion and Questions > General GM Chat

General GM Chat Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

LinkBack Thread Tools Search this Thread
Old 10-05-2003, 12:04 AM   #21
Junior Member
Posts like a Ricer Type-R
Join Date: Aug 2002
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road

Mn, could be knocking. Not a bad call. What octane, Nytro? Some of it may be heat related too. The M62 develops alot more heat than the M90 at the same engine rpms. The 62 has to spin faster. Could also be your ignition. I'm beginning to have my doubts about the stock ignition system keeping up under high stress. The MSD coils made a big difference for me.
willwren is offline   Reply With Quote
Old 10-06-2003, 07:14 AM   #22
Senior Member
Posts like a Turbo
Join Date: Apr 2003
Location: Central Maryland
Posts: 463
Thanks: 0
Thanked 0 Times in 0 Posts
Nytro67 is on a distinguished road

I thought it could be knocking too, i have a scan tool and the knock sensor isnt going crazy like i thought it would. I have this DIS-4 on my workbench for about 3 months now, i got the coil packs in a while back. WHIle it gave me a subtle upgrade in pedal response it didnt help at 99.6% throttle. I have a computer chip being custom burned that i've been waiting over 2 months for, it is supposed to change my spark curve a few degrees among other things. I really wanted to get that in and evaluate before i installed the DIS-4. Hopefully the chip will be ready this week. If i could figure this thing out i think i could hit high 14'*.
Will, you mention something about heat, i notice something that doesnt show up on any computers. I run like a bat out of hell up to the point where i get hot, then even when the guage says it cools back down to 180*, it still doesnt seem like the power is there like it was before everything started sizzling. I'm wondering if its the IAT sensor telling me to run rich because the air intake is soo hot. A mini AFC 2.0 should help in that respect. I do have a insulation box that i made around the cone filter and also have a heat sleeve for the intake pipe. that seeemed to help some also.

These are the next step to try and resolve the issue. Already paid for just waiting for chip.
computer chip

If i still have issues after that, then this is next in order...

Mini AFC
Cryo system

Anything else you can think of?

OH, i had this car since 97 and have never put anything but high Octane in.
'05 Pontiac Grand Prix GTP Comp G not quite Bone Stock
have the Aftermarket Pontiac Silver Grille inserts and the Pontiac aftermarket exhaust tips and 35% tint!
Retired the Black 95 SSEi :(
Fire sale. uuhh, i mean for sale.
Nytro67 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Domestic Driver Magazine needs submissions! Lounge 21 03-26-2007 08:16 PM
Need submissions for Domestic Driver E-zine! Lounge 9 10-09-2006 07:47 PM
Need submissions for Domestic Driver E-zine! Lounge 17 06-28-2006 09:15 PM
Techinfo article submissions/updates willwren General GM Chat 50 10-28-2005 11:10 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:21 AM.