2.2" pulley, getting bad belt slip at 4800rpm... - Page 6 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > Forced Induction

Forced Induction All questions and problems regarding Superchargers, Turbos, NOS, ZEX, intercoolers, water injection, etc.

LinkBack Thread Tools Search this Thread
Old 07-14-2004, 05:27 PM   #51
Senior Member
True Car Nut
Join Date: Aug 2003
Location: Salina, KS
Posts: 5,246
Thanks: 0
Thanked 0 Times in 0 Posts
TrueWildMan is on a distinguished road

No, the retainer is the U-shaped pin that sits in the groove just inside the nose-cone in front of the rubber nose-piece and behind the pulley. You can see it pretty plainly in this pic right in front of the rubber:

Click the image to open in full size.
TrueWildMan is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 05:42 AM
Studdering at WOT, belt slip? ymmot04 2000-2005 7 08-25-2009 12:28 AM
feel a little bump or "slip" in steering wheel ruby76 2000-2005 12 01-10-2007 08:48 AM
Gates belts and belt slip J Wikoff 1992-1999 2 11-28-2005 08:53 AM
Belt slip?? Red Baron 1992-1999 7 07-05-2003 06:00 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:50 AM.