Rear Defrost not working - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > Everything Electrical & Electronic

Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

LinkBack Thread Tools Search this Thread
Old 12-20-2007, 01:53 PM   #1
Junior Member
Toddster's Avatar
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Toddster is on a distinguished road
Default Rear Defrost not working

The car: friends 96SE w/manual climate controls (Not A C C)

Problem: The Rear defrost does not turn on. The round push button to the left of the fan *** will not light up indicating that the rear defrost is working.
All I hear when I push it in is a click somewhere behind the dash, probably the relay.
I did check the rear defrost fuse and it is not blown.

So, let me know what to check next.
Thanks for your help w/this.

Toddster is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear window defrost+command start SSEimatt93 Everything Electrical & Electronic 1 10-03-2005 02:59 PM
Rear Window Defrost / Defog Merlin 91/97 1987-1991 2 09-09-2005 08:08 AM
rear defrost L27Buick 1992-1999 6 03-01-2005 08:48 PM
Rear defrost/wiring problem jrmoen 1992-1999 1 01-31-2005 11:42 AM
rear defrost cuts out its840 Everything Electrical & Electronic 11 12-21-2004 12:54 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:17 AM.