Battery won't charge 1967 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > Everything Electrical & Electronic

Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

LinkBack Thread Tools Search this Thread
Old 05-11-2009, 09:28 AM   #1
Junior Member
Join Date: May 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mugsy is on a distinguished road
Default Battery won't charge 1967

This car wasn't hooked up electrically when I bought it. Bought new battery, new alternator, and new regulator. After many hours, got it wired and working then I lost the alternator belt. Installed new belt and now the car runs but the battery won't charge. Things I checked:[LIST=1][*]Had alternator tested OK[*]Have 12.5 volts at "bat" terminal of alternator[*]Have 12.5 volts from ignition switch to pin 3 of voltage regulator[*]There is no voltage on the "F" line between the regulator and the alternator[*]Fusible link ok[*]Commons and grounds connected[*]Took alternator apart and everything looks good.

This looks like a very simple circuit and I am at wits end (won't be the last time I'm sure).
Is it possible that the alternator check gave a false positive?

Last edited by Mugsy; 05-11-2009 at 09:30 AM.
Mugsy is offline   Reply With Quote
Old 05-11-2009, 10:00 AM   #2
Retired Senior Admin

Expert Gearhead
Danthurs's Avatar
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 14 Times in 11 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all

Check the cables. Even if they look good they might not be. Check the tech info area for testing. I put some tests there for checking the chrging system. Even though your car is much older the testing should still be close.
Danthurs is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Code 41 car won't keep charge when on.! LivieBoo Pontiac 8 09-19-2013 09:13 PM
Need to beat a 1967 fairlane V8. Vaughan221 Performance, Brainstorming & Tuning 2 08-14-2004 08:29 AM
Won't hold charge compressor running when car is shut off gowilly20 1992-1999 4 01-22-2004 12:34 AM
Exterior lights and battery charge level repinS 1987-1991 6 09-09-2003 12:52 PM
1967 Bonneville complinitor Classics (Star Chief and 1957 to 1986) 9 08-11-2003 11:04 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:35 PM.