Transmission in '96 Regal - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick From the Electra, Lesabre, Park Avenue, Regal, to the Grand National. Here's the place for all things "Buick"

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-09-2016, 08:48 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
KLRutter is on a distinguished road
Angry Transmission in '96 Regal

I have a 1996 Buick Regal. Until recently, it'* ran fan. And then, this past Sunday (as of the time of this post), the RPMs began to shoot up to 5 and 6 and the car lost acceleration. I thought it needed more transmission fluid, but today I found out that I had put too much in it. So my dad and I drained the pan and refilled it, but the car refused to go into gear. Let me rephrase -- it would go into gear, but it wouldn't go anywhere. I found several posts on various sites about how it might be a transmission pump or a transmission lockup solenoid, but the results upon testing them were still the same -- no acceleration at all. Does anyone know how this can be fixed without the need for a mechanic?
KLRutter is offline   Reply With Quote
Old 08-10-2016, 09:48 PM   #2
Senior Member


Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 1,661
Thanked 672 Times in 512 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Got one of these?


Attached Thumbnails
Transmission in '96 Regal-080929-glossy-black-icon-business-wand1-sc43.png  
Tech II is offline   Reply With Quote
Old 08-11-2016, 09:52 AM   #3
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,743
Thanked 209 Times in 171 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Tech II'* point is you need a mechanic.
2kg4u is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Transmission line disconnects at radiator?? 02 regal Chilliscale@gmail. Buick 12 05-12-2016 09:32 AM
04 Regal -- question re transmission filter seal eclipse60 Buick 5 05-08-2014 05:05 PM
1991 Regal Which Transmission? Soft Ride Buick 2 08-20-2012 07:19 PM
Buick Regal Replacement.. Custom88 Lounge 8 01-28-2004 10:17 PM
Regal GS VS. GTP Video! GTX COWBOY General GM Chat 25 09-08-2003 10:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:12 PM.