Running amp wire? - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > GM Technical Discussion and Questions > Audio (and aftermarket electronics)

Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

LinkBack Thread Tools Search this Thread
Old 10-21-2007, 02:17 AM   #11
Posts like a V-Tak
Join Date: Jun 2007
Location: SF Bay Area
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Mike Sessei is on a distinguished road

Sorry to bump, but did no one else catch that great pun? Whether swerve intended or not - double thumbs on that one!
Mike Sessei is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Im Not Sure>>>>>>^*&(&(&(& Cookseytonyc 1992-1999 4 08-19-2009 05:59 PM
&%(*#(#($&Y^&#&$*(%(^%)%^) willwren Lounge 24 10-11-2007 05:56 PM
$&)$&*)#&+()#%& )#@(%&#)%*(&+_ Maymybonnieliveforevr Lounge 6 05-02-2007 06:07 PM
mom & hailey, mom & kim, mom & kim & mom harofreak00 Lounge 6 04-09-2007 02:40 PM
Running power wire for amp sambo4us Audio (and aftermarket electronics) 2 03-10-2007 03:17 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:05 AM.