Windshield fluid leaking...badly.... - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1992-1999

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 10-12-2004, 03:22 PM   #11
Posts like a V-Tak
Join Date: Feb 2004
Location: College Station, Texas
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
SynthDude2001 is on a distinguished road

Yep, that was the problem....the hose had gotten knocked loose somehow. I found it, reconnected it, and the windshield washers work just fine now. The fit wasn't all that tight, so I may look into gluing it or something later - but I used the washer a few times and it stayed on, so I'll leave it alone for now.

I think I also located what must have been the pump for the headlight washers, it was on the other side of the tank near the outer body panel. Strangely enough, I didn't see a hose running up to it, or even a place where a hose could have gone - but the view was somewhat obscured and I didn't have a flashlight. It'* not that important though, so I'll mess with it at some other point. I thought I noticed just a little bit of the fluid on the ground, but that may have already been in the parking space when I pulled up. In any case, the fluid wasn't draining out like it had been before, so I'm happy.

Now, if I can just manage to install that O2 sensor I've ordered without destroying anything... :P
SynthDude2001 is offline   Reply With Quote
Old 10-13-2004, 11:08 AM   #12
Senior Member
Posts like a Northstar
Join Date: Jan 2002
Location: southern California
Posts: 538
Thanks: 0
Thanked 0 Times in 0 Posts
billha is on a distinguished road

Consider yourself lucky. On my '93 SSEi, both windshield washer pumps have developed leaks over time and had to be replaced. One of the pumps leaked around the shaft seal, and the other pump leaked through the plastic body itself. And no, I don't add battery acid or anything else to the washer fluid tank...just regular ol' premixed windshield washer solution.
billha is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Right side of trunk is leaking badly pontiacandryan 1992-1999 5 09-26-2009 04:29 AM
HUD Windshield vs NON-HUD Windshield Hans General GM Chat 15 09-16-2007 10:10 AM
1992 Bonneville SE - engine stutters badly wont idle - 2ntense 1992-1999 6 11-01-2006 03:52 PM
need friendship advice (badly) corvettecrazy Lounge 37 01-23-2006 12:38 AM
Emergency! Badly leaking roof Steilhand 1987-1991 6 11-25-2004 09:52 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:28 PM.