Service info: 1992 SSEI Instrument Cluster - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1992-1999

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 07-27-2003, 09:43 PM   #1
Senior Member
Posts like a Turbo
Join Date: Jul 2003
Location: Boston Area
Posts: 327
Thanks: 0
Thanked 0 Times in 0 Posts
TelePlayer is on a distinguished road
Default Service info: 1992 SSEI Instrument Cluster

When I first got my SSEI, the instrument cluster was bad. It would work fine, then all of a sudden parts of it would go dim, and the "ding ding" sound would go off. It did some pretty crazy things. I tried playing with the main connector, etc. I even took it out and powered it up on the bench, but I couldn't find the intermittant connection.

I finally exchanged it at some place in NC or SC, can't remember right now. But they were great. I told them the mileage over the phone and they set it and sent it to me. When you take out the I/C, don't even bother without lowering the steering wheel. Besides, I always permanently remove the "hush panel" near your feet, the one that holds the diagnostic connector. I can't stand my toes hitting that panel when I go from gas to brake. This is also a good time to replace the headlamp switch if your instrument panel dimmer is messed up, like most are.

If you are real picky like I am, buy a new I/C lens and install it on your new cluster. When cleaning the lens, NEVER "polish" it or use a vacuum with a brush on it. It will scratch the lens. The only thing I use is an old t-shirt with a little water on it. Just wipe it once or twice and then leave it alone. Every time you touch it, it gets a little worse.

It'* been over a year, and so far my new cluster is still good. It also had the fix that keeps the gas gauge from reading empty when it is totally full. The gas gauge, I will save that for another post.

Hope this is helpful,
TelePlayer is offline   Reply With Quote
Old 10-02-2008, 01:07 PM   #2
Junior Member
Join Date: Mar 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Animal90 is on a distinguished road

Any chance you can remeber where you got your insturment cluster fixed? Mine is dead, i have already pulled it apart and checked all the connections. I also tried a new headlight switch. I would like to send it out and get it fixed.
Animal90 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Cluster 1992 SSE problem homer153091 Everything Electrical & Electronic 7 09-09-2008 07:33 PM
1992 SSE INSTRUMENT CLUSTER PROBLEMS JUNIOR74 Everything Electrical & Electronic 1 04-20-2008 08:59 PM
Service info: 1992 SSEI crank sensor TelePlayer 1992-1999 2 08-02-2003 09:51 AM
Service Info 1992 SSEI transmission and p/s lines TelePlayer 1992-1999 5 07-27-2003 11:41 PM
Service Info: 1992 SSEI front wheel bearings (hubs) TelePlayer 1992-1999 0 07-27-2003 10:08 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:58 PM.