Instrument cluster does not light up. (94 Bonneville) - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1992-1999

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 01-09-2005, 09:28 AM   #11
Posts like a V-Tak
Join Date: Oct 2003
Location: Hawthorn Woods, Il (By Mundelein, Lake Zurich)
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
evilsaint is on a distinguished road

Do you guys know if the same problem (unlit dash backlights) could potentially be caused by the same HL switch shorting out on a 96+? I'm still searching for easier fixes than pulling the whole dash :(
evilsaint is offline   Reply With Quote
Old 01-09-2005, 02:28 PM   #12
Senior Member
True Car Nut
Join Date: Mar 2004
Location: Ames, Iowa
Posts: 3,066
Thanks: 0
Thanked 1 Time in 1 Post
bill buttermore is on a distinguished road

Originally Posted by Ogantai
Is there any documentation available on the Bonneville audio system? I have a feeling I have lots of reconnections to make... :(
The connections to the stock radio and speakers are clearly laid out in the factory service manual. I'm pretty sure someone on the site is gonna have an FSM for 94. If you can't find the '94 info, I can look it up in mine, but mine is for '92 SSE, SSEi and may be a bit different.
bill buttermore is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any recommendations for instrument cluster light bulbs for 91 Olds 88 Royale? SUPERDUDEGTA Oldsmobile 4 02-25-2015 12:26 AM
Instrument cluster swap on 95 Bonneville SSEI Crece Pontiac Bonneville 2 10-20-2011 03:46 AM
'98 Bonneville, Instrument cluster issues hotrod53 1992-1999 28 04-28-2010 12:56 PM
Failed C/E light, Instrument cluster, and left signal return G2SSEi95 Everything Electrical & Electronic 16 07-12-2005 12:22 AM
another instrument cluster question egladman 1987-1991 4 07-02-2003 11:53 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:15 PM.