Gas Mileage Suddenly Dropped! HELP! - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1992-1999

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 03-18-2003, 09:28 AM   #11
Senior Member
Posts like a Turbo
Join Date: Dec 2002
Location: Knox, Indiana
Posts: 398
Thanks: 0
Thanked 0 Times in 0 Posts
tutu67 is on a distinguished road

Well I will trust him, this coming next paycheck I will have my brother get it for me. I lack the credit card.
tutu67 is offline   Reply With Quote
Old 03-18-2003, 09:51 PM   #12
Posts: n/a

Originally Posted by jr's3800
Originally Posted by tutu67
Is $62 too much to pay for an O2 sensor. It was at NAPA, or should I go to the GM dealer I got in town?
I'd say go with the factory part.... Youll be better off getting the sensor through It'll be cheaper... You need the same sensor as my 95 bonneville... The only one you need is the one in the rear manifold before the converter..
you will need the same sensor as me... you have a 96 Bonneville correct?... If so you will need P/N 25312184 this will be a genuine GM O2 sensor... the sensor is a little better than $34 and the shipping is around $7 if memory serves.... If you have any other questions let us know or send me a PM...
Umm... I was told that a new O2 sensor would be $75 +tax at the local GM parts department...
  Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas, Oil And Gas Mileage **** SERIES II ENGINES**** Nashville Cowboy General GM Chat 26 02-06-2007 05:23 PM
Ok my mileage dropped,is it because of 10w30 oil 1998 Bonnev cvc 1992-1999 9 09-11-2005 03:34 PM
4T60E had TCC clutch failure issues but suddenly drives fine 1997_LeSabre 1992-1999 3 12-26-2004 05:04 PM
94 SE Looses ALL electrical power suddenly? Maclover94 1992-1999 8 11-08-2004 07:56 PM
A//C Suddenly not working malatu 2000-2005 4 07-25-2004 07:00 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:33 PM.