1995 Bonneville SE >> Codes and Questions - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1992-1999

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 05-03-2008, 06:42 PM   #1
Junior Member
Join Date: May 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
phaT-X is on a distinguished road
Default 1995 Bonneville SE >> Codes and Questions

I've been having probs with my Bonneville, they started after the Plenum cracked and water went into my intake/engine, after that was fixed, it ran great for a few months, then it randomly started stalling out and dinging 3 times when it stalled, I did some research and figured it was the crank angle sensor.. but I checked under my hood and found some vacuum hoses so badly rotted out and intake (plenum) bolts loose, I figured maybe that was it and fixed all that, I also removed some sensors to make sure water/coolant did'nt contaminate them, after I did that, a new problem occured and I believe it was because I removed my IAC sensor, I did'nt know it had a set distance on it and just put it back in and I had moved it when I tried to clean it with a soft towel.

So now it surges too.. I found out the distance should be less that 1 & 1/8 inch (or 28mm) and pushed it back in, but I still have the same problem.

I went and had a diagnostics test done and it gave me codes P0101 and P0321, which is the MAF sensor and Crack Angle sensor, I figured the Crank sensor was bad, but I was wondering if a malfunctioning IAC sensor could also produce the P0101 code or make the MAF sensor not work correctly? It just seems strange that the 2nd problem occured after I messed with the IAC sensor, yet get a code for the MAF sensor..
phaT-X is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Bonneville SE audio questions Gamedragon11290 Audio (and aftermarket electronics) 5 10-21-2008 09:58 PM
Questions,Questions,Questions.......... dbeast420 Lounge 2 05-06-2006 02:49 AM
1995 Pontiac Bonneville SE vs 1995 Dodge Avenger ES killer_cr80r General GM Chat 30 03-28-2004 03:15 AM
Questions questions questions big_boss2010 1992-1999 2 09-06-2003 12:41 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:56 AM.