1994 cam sensor code - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1992-1999

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 08-14-2008, 11:26 PM   #1
Junior Member
Join Date: Aug 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
wsimmons3 is on a distinguished road
Smile 1994 cam sensor code

I have a 94 Bonneville with an "L" code 3800 engine. The check engine light comes on regularly. It often comes on within a few seconds of starting the car. Other times it comes on after it runs for a while. It may be off for two weeks at a time, but is on more than it is off. The code is cam sensor failure. I have replaced the cam and crank sensor. Changed the plugs and wires. When the light is on the engine misses periodically. 99% of the time it is barely noticeable only when you take your foot off of the gas. Other times, I will be driving at 70 mph. After 30 minutes or so, it looses all power. It misses and acts as if it is being starved of air. If you press the petal down until it downshifts, it will start to act normal and accelerate. It loose power again once you let off of the gas. This will go away after a couple minutes. It has 156,000 miles. The exhaust is original, but does not seem to be bad. It passes the states exhaust gas certification with very good results. I do not see a difference in the gas mileage. Once in a while I notice a pressure build up in the gas tank. It will vent for a few seconds when the cap is removed. This happens mostly after driving for an hour with a low gas tank. Any ideas. This thing has been driving me crazy for the last year.

wsimmons3 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cam sensor code, ignition weirdness; need an oldsmobro's wisdom and guidance. Kevin the bro Oldsmobile 7 04-30-2015 02:30 AM
'92 Park Ave Ultra: Code 41 (Cam Sensor Circuit) DJ-HI-TEC Buick 8 06-07-2013 08:49 PM
I replaced Cam Sensor and still no fix. (Code 42) porksoda Oldsmobile 8 11-12-2011 06:43 PM
HELP! cam sensor error... and its NOT the cam sensor Sprig Everything Electrical & Electronic 3 06-17-2006 10:13 AM
code 41- cam sensor circuit pdqSSEi 1992-1999 8 04-10-2006 11:06 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:53 PM.