idles to high - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > Pontiac Bonneville > 1987-1991

1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

LinkBack Thread Tools Search this Thread
Old 03-31-2007, 10:52 PM   #1
Posts like a V-Tak
Join Date: Mar 2007
Location: eastlake ohio 44095
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
buck912 is on a distinguished road
Default idles to high

okay so i was suggested a vacum leak but its not there all good seners are good except for my qdm i think the one that controls my egr cause my egr dont turn on so i have switches routed to it my plugs are gapped properly and everything is in its place its just that when i first start her she will go to about 1500 rpms then stall doit a couple of times and it will stay started when she finally stay runnin she will idle between 1000 and 1500 rpms then drop to a thou for awhile then start to rise to 2thou i can give it a little gas and it will work back down to a thou till 10 15 minutes later she will steadly rise to 2000 rpms sometimes 3 any ideas
buck912 is offline   Reply With Quote
Old 04-08-2007, 04:59 PM   #2
Senior Member
True Car Nut
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road

Idk man, but I have the exact same problem. QDM codes that come on right with tcc lockup, and turn off at 34mph. Oddest thing ever. My fans don't turn on in traffic, but shorting the A and B terminals to check codes, turns them both on. Also my EGRs don't appear to be working, and when they do work my idle seems fine, IMO. I do have a few vacuum leaks, you don't by chance have a messed up PCV system, the hose from the valve cover to the TB, and the valve itself and gromet on the intake?

I too would like to know the culprit here, for the most part it got a lot better with new intake gaskets, but it'* still there, and its only every 2 out of 5 times i have the car out of gear does it idle around 2k, sometimes it'd be 3k as well... but that has long past with new intake gaskets.
'89 SSE - GX3 -190k, 155k on body - Back for another ride.
opensourceguy is offline   Reply With Quote
Old 04-09-2007, 11:25 AM   #3
Senior Member
Certified GM nut
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default idle

It sounds like vacuum to me. Either your pcv has failed or you have a bad grommet. Egr'* stuck open can also cause this as well as a faulty IAC valve. you should also check you TPS voltage at the idle position to see if its correct.
SSEBONNE4EVA is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
car idles @ 3500 rpm at start and 1900 rpm in drive? 88bonnsse 1987-1991 15 01-27-2008 03:41 AM
car idles at 1000 rpms. is this normal? 88bonnsse 1992-1999 4 01-22-2008 09:32 PM
stalls & jerks when cold when warmed up idles rough 92olds88royale Oldsmobile 4 02-01-2006 07:09 AM
A rattle when the car idles. Maestro 1987-1991 6 08-19-2005 11:08 PM
93 ssei idles rough mekobes44 1992-1999 4 07-15-2004 10:15 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:07 PM.